ModelMultipleChoiceField in Django 1.6.x before 1.6.10 and 1.7.x before 1.7.3, when…
Priority LOW 28CWE-17Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
ModelMultipleChoiceField in Django 1.6.x before 1.6.10 and 1.7.x before 1.7.3, when show_hidden_initial is set to True, allows remote attackers to cause a denial of service by submitting duplicate values, which triggers a large number of SQL queries.
Why it matters now
EPSS 0.0269 85th percentileScored 2026-11-07
Fix Fixed Django (PyPI): 1.6.10, 1.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.6 to before 1.6.10 | 1.6.10 | Patch available | GHSA-6g95-x6cj-mg4v |
| — | Django (PyPI) | 1.7 to before 1.7.3 | 1.7.3 | Patch available | GHSA-6g95-x6cj-mg4v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.6 to before 1.6.10 Fixed in 1.6.10 Patch available GHSA-6g95-x6cj-mg4v
- Django (PyPI) Vendor— Affected 1.7 to before 1.7.3 Fixed in 1.7.3 Patch available GHSA-6g95-x6cj-mg4v
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:10.04:*:lts:*:*:*:*:* | 10.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:lts:*:*:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:* | 14.10 | Vulnerable | Canonical |
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | up to 1.4.17 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:* | 1.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:* | 1.6.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:* | 1.6.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:* | 1.6.4 | Vulnerable | djangoproject |
- cpe:2.3:o:canonical:ubuntu_linux:10.04:*:lts:*:*:*:*:* Versions 10.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:lts:*:*:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:* Versions 14.10 Vulnerable ·Canonical
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.4.17 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:* Versions 1.6.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:* Versions 1.6.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:* Versions 1.6.4 Vulnerable ·djangoproject
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:* | 1.6.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:* | 1.6.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:* | 1.6.7 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:* | 1.6.8 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:* | 1.6.9 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:* | 1.7 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:* | 1.7.2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:* Versions 1.6.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:* Versions 1.6.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:* Versions 1.6.7 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:* Versions 1.6.8 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:* Versions 1.6.9 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:* Versions 1.7 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:* Versions 1.7.2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-6g95-x6cj-mg4v Django (PyPI) Fixed in 1.6.10 Advisory →
- Fix · GHSA-6g95-x6cj-mg4v Django (PyPI) Fixed in 1.7.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0222
- 2026-10-03 Alias added: GHSA-6g95-x6cj-mg4v
References
Advisory 7
Other 8
- http://advisories.mageia.org/MGASA-2015-0026.html
- https://github.com/django/django/commit/bcfb47780ce7caecb409a9e9c1c314266e41d392
- https://github.com/django/django/commit/d7a06ee7e571b6dad07c0f5b519b1db02e2a476c
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2015-7.yaml
- https://web.archive.org/web/20161201073154/http://secunia.com/advisories/62285
- https://web.archive.org/web/20161201073337/http://secunia.com/advisories/62309
- https://www.djangoproject.com/weblog/2015/jan/13/security
Sources
- CVE-2015-0222 · CVE Program
- CVE-2015-0222 · NVD
- FIRST EPSS
- GHSA-6g95-x6cj-mg4v · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0222 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences