RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API…
Priority LOW 23CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the get_repo API method.
Why it matters now
EPSS 0.01858 79th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed RhodeCode (PyPI): 2.2.7Kallithea (PyPI): 0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | RhodeCode (PyPI) | before 2.2.7 | 2.2.7 | Patch available | GHSA-hhx9-4vw2-x54r |
| — | Kallithea (PyPI) | before 0.2 | 0.2 | Patch available | GHSA-hhx9-4vw2-x54r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- RhodeCode (PyPI) Vendor— Affected before 2.2.7 Fixed in 2.2.7 Patch available GHSA-hhx9-4vw2-x54r
- Kallithea (PyPI) Vendor— Affected before 0.2 Fixed in 0.2 Patch available GHSA-hhx9-4vw2-x54r
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kallithea-scm:kallithea:0.1:*:*:*:*:*:*:* | 0.1 | Vulnerable | Kallithea-scm |
| cpe:2.3:a:rhodecode:rhodecode_enterprise:*:*:*:*:*:*:*:* | up to 2.2.6 | Vulnerable | Rhodecode |
- cpe:2.3:a:kallithea-scm:kallithea:0.1:*:*:*:*:*:*:* Versions 0.1 Vulnerable ·Kallithea-scm
- cpe:2.3:a:rhodecode:rhodecode_enterprise:*:*:*:*:*:*:*:* Versions up to 2.2.6 Vulnerable ·Rhodecode
Remediation
- Fix · GHSA-hhx9-4vw2-x54r RhodeCode (PyPI) Fixed in 2.2.7 Advisory →
- Fix · GHSA-hhx9-4vw2-x54r Kallithea (PyPI) Fixed in 0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0260
- 2026-10-03 Alias added: GHSA-hhx9-4vw2-x54r
References
Exploit 2
Other 5
- https://github.com/pypa/advisory-database/tree/main/vulns/kallithea/PYSEC-2015-29.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/rhodecode/PYSEC-2015-32.yaml
- https://kallithea-scm.org/repos/kallithea/changeset/5923d74742879b812965568475e21c3496d722a9
- https://rhodecode.com/blog/rhodecode-enterprise-security-release
- https://web.archive.org/web/20150321135511/http://www.securityfocus.com/bid/72573
Sources
- CVE-2015-0260 · CVE Program
- CVE-2015-0260 · NVD
- FIRST EPSS
- GHSA-hhx9-4vw2-x54r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences