Read the docs
TI-2015-00237 Aliases CVE-2015-0270GHSA-v59p-p692-v382

Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.

Priority MEDIUM 44CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.

Why it matters now

EPSS 0.01103 65th percentileScored 2026-11-07
Fix Fixed zendframework/zendframework (Packagist): 2.2.10, 2.3.5zendframework/zend-db (Packagist): 2.2.10, 2.3.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ZendZend Frameworkbefore 2.2.10 and 2.3.x before 2.3.5—No fix listedCNA
—zendframework/zendframework (Packagist)before 2.2.102.2.10Patch availableGHSA-v59p-p692-v382
—zendframework/zendframework (Packagist)2.3.0 to before 2.3.52.3.5Patch availableGHSA-v59p-p692-v382
—zendframework/zend-db (Packagist)before 2.2.102.2.10Patch availableGHSA-v59p-p692-v382
—zendframework/zend-db (Packagist)2.3.0 to before 2.3.52.3.5Patch availableGHSA-v59p-p692-v382
  • Zend Framework VendorZend Affected before 2.2.10 and 2.3.x before 2.3.5 Fixed in — No fix listed CNA
  • zendframework/zendframework (Packagist) Vendor— Affected before 2.2.10 Fixed in 2.2.10 Patch available GHSA-v59p-p692-v382
  • zendframework/zendframework (Packagist) Vendor— Affected 2.3.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-v59p-p692-v382
  • zendframework/zend-db (Packagist) Vendor— Affected before 2.2.10 Fixed in 2.2.10 Patch available GHSA-v59p-p692-v382
  • zendframework/zend-db (Packagist) Vendor— Affected 2.3.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-v59p-p692-v382

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:zend:framework:*:*:*:*:*:*:*:*before 2.2.10; 2.3.0 to before 2.3.5VulnerableZend
  • cpe:2.3:a:zend:framework:*:*:*:*:*:*:*:* Versions before 2.2.10; 2.3.0 to before 2.3.5 Vulnerable ·Zend

Remediation

  • Fix · GHSA-v59p-p692-v382 zendframework/zendframework (Packagist) Fixed in 2.2.10 Advisory →
  • Fix · GHSA-v59p-p692-v382 zendframework/zendframework (Packagist) Fixed in 2.3.5 Advisory →
  • Fix · GHSA-v59p-p692-v382 zendframework/zend-db (Packagist) Fixed in 2.2.10 Advisory →
  • Fix · GHSA-v59p-p692-v382 zendframework/zend-db (Packagist) Fixed in 2.3.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-0270
  2. 2026-10-03 Alias added: GHSA-v59p-p692-v382

References

  • TI-2011-03382 Zend Framework 1.11.3 in Zend Server CE 5.1.0 allows remote attackers to obtain sensitive… CVSS 2.0MEDIUM 5.0
  • TI-2009-04180 The shutdown function in the Zend_Log_Writer_Mail class in Zend Framework (ZF) allows… CVSS 2.0MEDIUM 5.0

Sources