Observable discrepancy in GNU Libgcrypt
Priority LOW 30CWE-203Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-203.
Summary
The mpi_powm function in Libgcrypt before 1.6.3 and GnuPG before 1.4.19 allows attackers to obtain sensitive information by leveraging timing differences when accessing a pre-computed table during modular exponentiation, related to a "Last-Level Cache Side-Channel Attack."
Why it matters now
EPSS 0.01952 80th percentileScored 2026-11-07
Fix Partial Libgcrypt (GNU): 1.6.3GnuPG (GNU): 1.4.19Red Hat: 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GNU | Libgcrypt | before 1.6.3 | 1.6.3 | Patch available | CNA |
| GNU | GnuPG | before 1.4.19 | 1.4.19 | Patch available | CNA |
- Libgcrypt VendorGNU Affected before 1.6.3 Fixed in 1.6.3 Patch available CNA
- GnuPG VendorGNU Affected before 1.4.19 Fixed in 1.4.19 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnupg:gnupg:*:*:*:*:*:*:*:* | before 1.4.19 | Vulnerable | GnuPG |
| cpe:2.3:a:gnupg:libgcrypt:*:*:*:*:*:*:*:* | before 1.6.3 | Vulnerable | GnuPG |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:gnupg:gnupg:*:*:*:*:*:*:*:* Versions before 1.4.19 Vulnerable ·GnuPG
- cpe:2.3:a:gnupg:libgcrypt:*:*:*:*:*:*:*:* Versions before 1.6.3 Vulnerable ·GnuPG
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA Libgcrypt (GNU) Fixed in 1.6.3
- Fix · CNA GnuPG (GNU) Fixed in 1.4.19
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Virtualization 3 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0837
- 2026-10-03 Alias added: GHSA-3ccv-3j4f-926q
References
More GNU vulnerabilities
- TI-2026-19388 telnetd in GNU Inetutils through 2.7 allows remote authentication bypass via a "-f root"… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05164 GNU Bash through 4.3 bash43-026 does not properly parse function definitions in the… KEVCVSS 3.1HIGH 8.8
- TI-2023-04522 Glibc: buffer overflow in ld.so leading to privilege escalation KEVCVSS 3.1HIGH 7.8
- TI-2009-03392 The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-0837 · CVE Program
- CVE-2015-0837 · NVD
- FIRST EPSS
- GHSA-3ccv-3j4f-926q · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0837 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences