Apport privilege escalation through Python module imports
Priority LOW 34CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-264.
Summary
Any Python module in sys.path can be imported if the command line of the process triggering the coredump is Python and the first argument is -m in Apport before 2.19.2 function _python_module_path.
Why it matters now
EPSS 0.00429 37th percentileScored 2026-11-07
Fix Fixed Apport (Ubuntu): 2.0.1-0ubuntu17.13, 2.19.1-0ubuntu4, 2.17.2-0ubuntu1.7 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubuntu | Apport | before 2.0.1-0ubuntu17.13; before 2.19.1-0ubuntu4; before 2.17.2-0ubuntu1.7; before 2.14.1-0ubuntu3.18; before 2.19.2 | 2.0.1-0ubuntu17.13, 2.19.1-0ubuntu4, 2.17.2-0ubuntu1.7, 2.14.1-0ubuntu3.18, 2.19.2 | Patch available | CNA |
- Apport VendorUbuntu Affected before 2.0.1-0ubuntu17.13; before 2.19.1-0ubuntu4; before 2.17.2-0ubuntu1.7; before 2.14.1-0ubuntu3.18; before 2.19.2 Fixed in 2.0.1-0ubuntu17.13, 2.19.1-0ubuntu4, 2.17.2-0ubuntu1.7, 2.14.1-0ubuntu3.18, 2.19.2 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* | 15.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* | 15.10 | Vulnerable | Canonical |
| cpe:2.3:a:canonical:apport:*:*:*:*:*:*:*:* | before 2.19.2 | Vulnerable | Canonical |
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* Versions 15.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* Versions 15.10 Vulnerable ·Canonical
- cpe:2.3:a:canonical:apport:*:*:*:*:*:*:*:* Versions before 2.19.2 Vulnerable ·Canonical
Remediation
- Fix · CNA Apport (Ubuntu) Fixed in 2.0.1-0ubuntu17.13, 2.19.1-0ubuntu4, 2.17.2-0ubuntu1.7, 2.14.1-0ubuntu3.18, 2.19.2
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1341
- 2026-10-03 Alias added: GHSA-gm79-rmm9-x7g9
References
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2015-1341 · CVE Program
- CVE-2015-1341 · NVD
- FIRST EPSS
- GHSA-gm79-rmm9-x7g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences