Read the docs
TI-2015-01630 Aliases CVE-2015-1813GHSA-9h85-v6xf-h26q

Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2…

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1812.

Why it matters now

EPSS 0.01769 78th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.606, 1.596.2Red Hat: 2 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)1.597 to before 1.6061.606Patch availableGHSA-9h85-v6xf-h26q
—org.jenkins-ci.main:jenkins-core (Maven)before 1.596.21.596.2Patch availableGHSA-9h85-v6xf-h26q
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.597 to before 1.606 Fixed in 1.606 Patch available GHSA-9h85-v6xf-h26q
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.596.2 Fixed in 1.596.2 Patch available GHSA-9h85-v6xf-h26q

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 1.596.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 1.605VulnerableJenkins
cpe:2.3:a:redhat:openshift:*:*:*:*:enterprise:*:*:*up to 3.1VulnerableRed Hat
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 1.596.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.605 Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift:*:*:*:*:enterprise:*:*:* Versions up to 3.1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-9h85-v6xf-h26q org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.606 Advisory →
  • Fix · GHSA-9h85-v6xf-h26q org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.596.2 Advisory →

Red Hat 2 advisories

  • RHSA-2016:0070 Released 2016-01-26 · Red Hat rating Important
    Red Hat OpenShift Enterprise 3.1.1 bug fix and enhancement update
    • Red Hat OpenShift Enterprise 3.1 atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-redistributable-3.1.1.6-1.git.0.b57e8bd.el7aos +47
  • RHSA-2015:1844 Released 2015-09-30 · Red Hat rating Important
    Red Hat OpenShift Enterprise 2.2.7 security, bug fix and enhancement update
    • Red Hat OpenShift Enterprise Client 2.2 rhc-1.37.1.2-1.el6op
    • Red Hat OpenShift Enterprise Infrastructure 2.2 openshift-origin-broker-1.16.2.10-1.el6op, openshift-origin-broker-util-1.36.2.2-1.el6op, openshift-origin-logshifter-1.10.1.2-1.el6op +5
    • Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 openshift-origin-cartridge-jbosseap-2.26.3.1-1.el6op
    • Red Hat OpenShift Enterprise Node 2.2 jenkins-1.609.1-1.el6op, openshift-origin-cartridge-diy-1.26.1.1-1.el6op, openshift-origin-cartridge-haproxy-1.30.1.1-1.el6op +12

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3.1Fixed RHSA-2016:0070
Red Hat OpenShift Enterprise Client 2.2Fixed RHSA-2015:1844
Red Hat OpenShift Enterprise Infrastructure 2.2Fixed RHSA-2015:1844
Red Hat OpenShift Enterprise JBoss EAP add-on 2.2Fixed RHSA-2015:1844
Red Hat OpenShift Enterprise Node 2.2Fixed RHSA-2015:1844

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-1813
  2. 2026-10-03 Alias added: GHSA-9h85-v6xf-h26q

References

Sources