The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might…
Priority LOW 30CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The Ruby http gem before 0.7.3 does not verify hostnames in SSL connections, which might allow remote attackers to obtain sensitive information via a man-in-the-middle-attack.
Why it matters now
EPSS 0.01521 74th percentileScored 2026-11-07
Fix Fixed http (RubyGems): 0.7.3, 0.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | http (RubyGems) | 0.7.0 to before 0.7.3 | 0.7.3 | Patch available | GHSA-6wpv-cj6x-v3jw |
| — | http (RubyGems) | before 0.6.4 | 0.6.4 | Patch available | GHSA-6wpv-cj6x-v3jw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- http (RubyGems) Vendor— Affected 0.7.0 to before 0.7.3 Fixed in 0.7.3 Patch available GHSA-6wpv-cj6x-v3jw
- http (RubyGems) Vendor— Affected before 0.6.4 Fixed in 0.6.4 Patch available GHSA-6wpv-cj6x-v3jw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:http.rb_project:http.rb:*:*:*:*:*:ruby:*:* | up to 0.7.2 | Vulnerable | Http.rb Project |
- cpe:2.3:a:http.rb_project:http.rb:*:*:*:*:*:ruby:*:* Versions up to 0.7.2 Vulnerable ·Http.rb Project
Remediation
- Fix · GHSA-6wpv-cj6x-v3jw http (RubyGems) Fixed in 0.7.3 Advisory →
- Fix · GHSA-6wpv-cj6x-v3jw http (RubyGems) Fixed in 0.6.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1828
- 2026-10-03 Alias added: GHSA-6wpv-cj6x-v3jw
References
Advisory 3
Other 6
- https://groups.google.com/forum/#%21topic/httprb/jkb4oxwZjkU
- https://github.com/httprb/http
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/http/CVE-2015-1828.yml
- https://groups.google.com/forum/#!topic/httprb/jkb4oxwZjkU
- https://my.diffend.io/gems/http/0.6.3/0.6.4
- https://my.diffend.io/gems/http/0.7.2/0.7.3
Sources
- CVE-2015-1828 · CVE Program
- CVE-2015-1828 · NVD
- FIRST EPSS
- GHSA-6wpv-cj6x-v3jw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences