Apache HBase 0.98 before 0.98.12.1, 1.0 before 1.0.1.1, and 1.1 before 1.1.0.1, as used…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-284.
Summary
Apache HBase 0.98 before 0.98.12.1, 1.0 before 1.0.1.1, and 1.1 before 1.1.0.1, as used in IBM InfoSphere BigInsights 3.0, 3.0.0.1, and 3.0.0.2 and other products, uses incorrect ACLs for ZooKeeper coordination state, which allows remote attackers to cause a denial of service (daemon outage), obtain sensitive information, or modify data via unspecified client traffic.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.hbase:hbase (Maven) | 0.98 to before 0.98.12.1 | 0.98.12.1 | Patch available | GHSA-p8xr-4v2c-rvgp |
| — | org.apache.hbase:hbase (Maven) | 1.0.0 to before 1.0.1.1 | 1.0.1.1 | Patch available | GHSA-p8xr-4v2c-rvgp |
| — | org.apache.hbase:hbase (Maven) | 1.1.0 to before 1.1.0.1 | 1.1.0.1 | Patch available | GHSA-p8xr-4v2c-rvgp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.hbase:hbase (Maven) Vendor— Affected 0.98 to before 0.98.12.1 Fixed in 0.98.12.1 Patch available GHSA-p8xr-4v2c-rvgp
- org.apache.hbase:hbase (Maven) Vendor— Affected 1.0.0 to before 1.0.1.1 Fixed in 1.0.1.1 Patch available GHSA-p8xr-4v2c-rvgp
- org.apache.hbase:hbase (Maven) Vendor— Affected 1.1.0 to before 1.1.0.1 Fixed in 1.1.0.1 Patch available GHSA-p8xr-4v2c-rvgp
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.0:*:*:*:*:*:*:* | 3.0.0.0 | Vulnerable | IBM |
| cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.1:*:*:*:*:*:*:* | 3.0.0.1 | Vulnerable | IBM |
| cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.2:*:*:*:*:*:*:* | 3.0.0.2 | Vulnerable | IBM |
| cpe:2.3:a:apache:hbase:0.98.0:*:*:*:*:*:*:* | 0.98.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.1:*:*:*:*:*:*:* | 0.98.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.2:*:*:*:*:*:*:* | 0.98.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.3:*:*:*:*:*:*:* | 0.98.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.4:*:*:*:*:*:*:* | 0.98.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.5:*:*:*:*:*:*:* | 0.98.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.6:*:*:*:*:*:*:* | 0.98.6 | Vulnerable | Apache |
- cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.0:*:*:*:*:*:*:* Versions 3.0.0.0 Vulnerable ·IBM
- cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.1:*:*:*:*:*:*:* Versions 3.0.0.1 Vulnerable ·IBM
- cpe:2.3:a:ibm:infosphere_biginsights:3.0.0.2:*:*:*:*:*:*:* Versions 3.0.0.2 Vulnerable ·IBM
- cpe:2.3:a:apache:hbase:0.98.0:*:*:*:*:*:*:* Versions 0.98.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.1:*:*:*:*:*:*:* Versions 0.98.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.2:*:*:*:*:*:*:* Versions 0.98.2 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.3:*:*:*:*:*:*:* Versions 0.98.3 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.4:*:*:*:*:*:*:* Versions 0.98.4 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.5:*:*:*:*:*:*:* Versions 0.98.5 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.6:*:*:*:*:*:*:* Versions 0.98.6 Vulnerable ·Apache
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hbase:0.98.6.1:*:*:*:*:*:*:* | 0.98.6.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.7:*:*:*:*:*:*:* | 0.98.7 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.8:*:*:*:*:*:*:* | 0.98.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.9:*:*:*:*:*:*:* | 0.98.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.10:*:*:*:*:*:*:* | 0.98.10 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.10.1:*:*:*:*:*:*:* | 0.98.10.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.11:*:*:*:*:*:*:* | 0.98.11 | Vulnerable | Apache |
| cpe:2.3:a:apache:hbase:0.98.12:*:*:*:*:*:*:* | 0.98.12 | Vulnerable | Apache |
- cpe:2.3:a:apache:hbase:0.98.6.1:*:*:*:*:*:*:* Versions 0.98.6.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.7:*:*:*:*:*:*:* Versions 0.98.7 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.8:*:*:*:*:*:*:* Versions 0.98.8 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.9:*:*:*:*:*:*:* Versions 0.98.9 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.10:*:*:*:*:*:*:* Versions 0.98.10 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.10.1:*:*:*:*:*:*:* Versions 0.98.10.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.11:*:*:*:*:*:*:* Versions 0.98.11 Vulnerable ·Apache
- cpe:2.3:a:apache:hbase:0.98.12:*:*:*:*:*:*:* Versions 0.98.12 Vulnerable ·Apache
Remediation
- Fix · GHSA-p8xr-4v2c-rvgp org.apache.hbase:hbase (Maven) Fixed in 0.98.12.1 Advisory →
- Fix · GHSA-p8xr-4v2c-rvgp org.apache.hbase:hbase (Maven) Fixed in 1.0.1.1 Advisory →
- Fix · GHSA-p8xr-4v2c-rvgp org.apache.hbase:hbase (Maven) Fixed in 1.1.0.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Fuse 6 | Affected | No fix yet |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix yet |
| Red Hat OpenShift Enterprise 2 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1836
- 2026-10-03 Alias added: GHSA-p8xr-4v2c-rvgp
References
Advisory 3
Other 3
- [www-announce] 20150525 CVE-2015-1836: Apache HBase remote denial of service, information integrity, and information disclosure vulnerability
- https://www.cloudera.com/documentation/other/security-bulletins/topics/csb_topic_1.html
- http://mail-archives.apache.org/mod_mbox/www-announce/201505.mbox/%3CCA+RK=_CFiTfQ2d0V+kuJx_y5izmYccaKjXaJ3V72KK7tbOhbkg@mail.gmail.com%3E
Sources
- CVE-2015-1836 · CVE Program
- CVE-2015-1836 · NVD
- FIRST EPSS
- GHSA-p8xr-4v2c-rvgp · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1836 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences