Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.
Why it matters now
EPSS 0.02061 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Django (PyPI): 1.7.6, 1.8b2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 1.7.6 | 1.7.6 | Patch available | GHSA-6565-fg86-6jcx |
| — | Django (PyPI) | 1.8a1 to before 1.8b2 | 1.8b2 | Patch available | GHSA-6565-fg86-6jcx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 1.7.6 Fixed in 1.7.6 Patch available GHSA-6565-fg86-6jcx
- Django (PyPI) Vendor— Affected 1.8a1 to before 1.8b2 Fixed in 1.8b2 Patch available GHSA-6565-fg86-6jcx
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | up to 1.7.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.8:beta1:*:*:*:*:*:* | 1.8 beta1 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.7.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.8:beta1:*:*:*:*:*:* Versions 1.8 beta1 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-6565-fg86-6jcx Django (PyPI) Fixed in 1.7.6 Advisory →
- Fix · GHSA-6565-fg86-6jcx Django (PyPI) Fixed in 1.8b2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat OpenStack Platform 4
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2015-2241
- 2026-10-03 Alias added: GHSA-6565-fg86-6jcx
References
Advisory 3
Other 7
- https://github.com/django/django/commit/2654e1b93923bac55f12b4e66c5e39b16695ace5
- https://github.com/django/django/commit/82c9169077a066995e3b00aac551bf1c8a89d98a
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2015-8.yaml
- https://web.archive.org/web/20150523054951/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:109/?name=MDVSA-2015:109
- https://web.archive.org/web/20171112005349/http://www.securityfocus.com/bid/73095
- https://www.djangoproject.com/weblog/2015/mar/09/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-2241 · CVE Program
- CVE-2015-2241 · NVD
- FIRST EPSS
- GHSA-6565-fg86-6jcx · GitHub Advisory Database · CC BY 4.0
- CVE-2015-2241 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences