The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The thoughtbot paperclip gem before 4.2.2 for Ruby does not consider the content-type value during media-type validation, which allows remote attackers to upload HTML documents and conduct cross-site scripting (XSS) attacks via a spoofed value, as demonstrated by image/jpeg.
Why it matters now
EPSS 0.02106 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed paperclip (RubyGems): 4.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | paperclip (RubyGems) | before 4.2.2 | 4.2.2 | Patch available | GHSA-6jvm-3j5h-79f6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- paperclip (RubyGems) Vendor— Affected before 4.2.2 Fixed in 4.2.2 Patch available GHSA-6jvm-3j5h-79f6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thoughtbot:paperclip:*:*:*:*:*:ruby:*:* | up to 4.2.1 | Vulnerable | thoughtbot |
- cpe:2.3:a:thoughtbot:paperclip:*:*:*:*:*:ruby:*:* Versions up to 4.2.1 Vulnerable ·thoughtbot
Remediation
- Fix · GHSA-6jvm-3j5h-79f6 paperclip (RubyGems) Fixed in 4.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-2963
- 2026-10-03 Alias added: GHSA-6jvm-3j5h-79f6
References
Advisory 5
More thoughtbot Paperclip vulnerabilities
- TI-2017-00837 Server-side request forgery in thoughtbot paperclip ruby gem CVSS 3.0CRITICAL 9.8
Sources
- CVE-2015-2963 · CVE Program
- CVE-2015-2963 · NVD
- FIRST EPSS
- GHSA-6jvm-3j5h-79f6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences