Read the docs
TI-2015-02856 Aliases CVE-2015-3227GHSA-j96r-xvjq-r9pg

The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before…

Priority LOW 30Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.

Why it matters now

EPSS 0.0423 91st percentileScored 2026-11-07
Fix Partial activesupport (RubyGems): 4.1.11, 4.2.2, 3.2.22Red Hat: 3 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—activesupport (RubyGems)4.0.0.beta1 to before 4.1.114.1.11Patch availableGHSA-j96r-xvjq-r9pg
—activesupport (RubyGems)4.2.0.beta1 to before 4.2.24.2.2Patch availableGHSA-j96r-xvjq-r9pg
—activesupport (RubyGems)before 3.2.223.2.22Patch availableGHSA-j96r-xvjq-r9pg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • activesupport (RubyGems) Vendor— Affected 4.0.0.beta1 to before 4.1.11 Fixed in 4.1.11 Patch available GHSA-j96r-xvjq-r9pg
  • activesupport (RubyGems) Vendor— Affected 4.2.0.beta1 to before 4.2.2 Fixed in 4.2.2 Patch available GHSA-j96r-xvjq-r9pg
  • activesupport (RubyGems) Vendor— Affected before 3.2.22 Fixed in 3.2.22 Patch available GHSA-j96r-xvjq-r9pg

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*13.1VulnerableopenSUSE
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*13.2VulnerableopenSUSE
cpe:2.3:a:rubyonrails:rails:4.1.0:*:*:*:*:*:*:*4.1.0VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.1:*:*:*:*:*:*:*4.1.1VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.2:*:*:*:*:*:*:*4.1.2VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.3:*:*:*:*:*:*:*4.1.3VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.4:*:*:*:*:*:*:*4.1.4VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.5:*:*:*:*:*:*:*4.1.5VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.6:*:*:*:*:*:*:*4.1.6VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.1.7:*:*:*:*:*:*:*4.1.7VulnerableRails
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
  • cpe:2.3:a:rubyonrails:rails:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.2:*:*:*:*:*:*:* Versions 4.1.2 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.3:*:*:*:*:*:*:* Versions 4.1.3 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.4:*:*:*:*:*:*:* Versions 4.1.4 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.5:*:*:*:*:*:*:* Versions 4.1.5 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.6:*:*:*:*:*:*:* Versions 4.1.6 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.1.7:*:*:*:*:*:*:* Versions 4.1.7 Vulnerable ·Rails
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:rubyonrails:rails:4.1.8:*:*:*:*:*:*:*4.1.8VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.2.0:*:*:*:*:*:*:*4.2.0VulnerableRails
cpe:2.3:a:rubyonrails:rails:4.2.1:*:*:*:*:*:*:*4.2.1VulnerableRails
  • cpe:2.3:a:rubyonrails:rails:4.1.8:*:*:*:*:*:*:* Versions 4.1.8 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Rails
  • cpe:2.3:a:rubyonrails:rails:4.2.1:*:*:*:*:*:*:* Versions 4.2.1 Vulnerable ·Rails

Remediation

  • Fix · GHSA-j96r-xvjq-r9pg activesupport (RubyGems) Fixed in 4.1.11 Advisory →
  • Fix · GHSA-j96r-xvjq-r9pg activesupport (RubyGems) Fixed in 4.2.2 Advisory →
  • Fix · GHSA-j96r-xvjq-r9pg activesupport (RubyGems) Fixed in 3.2.22 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
CloudForms Management Engine 5AffectedNo fix planned: Will not fix
Red Hat Software CollectionsAffectedNo fix planned: Will not fix
Red Hat Subscription Asset ManagerAffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-3227
  2. 2026-10-03 Alias added: GHSA-j96r-xvjq-r9pg

References

Sources