http/conn/ssl/SSLConnectionSocketFactory.java in Apache HttpComponents HttpClient before…
Priority LOW 38CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.
Summary
http/conn/ssl/SSLConnectionSocketFactory.java in Apache HttpComponents HttpClient before 4.3.6 ignores the http.socket.timeout configuration setting during an SSL handshake, which allows remote attackers to cause a denial of service (HTTPS call hang) via unspecified vectors.
Why it matters now
EPSS 0.1876 97th percentileScored 2026-11-07
Fix Partial org.apache.httpcomponents:httpclient (Maven): 4.3.6Red Hat: 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.httpcomponents:httpclient (Maven) | before 4.3.6 | 4.3.6 | Patch available | GHSA-fmj5-wv96-r2ch |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.httpcomponents:httpclient (Maven) Vendor— Affected before 4.3.6 Fixed in 4.3.6 Patch available GHSA-fmj5-wv96-r2ch
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* | 15.04 | Vulnerable | Canonical |
| cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* | 21 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* | 22 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* | 23 | Vulnerable | Fedoraproject |
| cpe:2.3:a:apache:httpclient:*:*:*:*:*:*:*:* | 4.3 – 4.3.5 | Vulnerable | Apache |
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* Versions 15.04 Vulnerable ·Canonical
- cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* Versions 21 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
- cpe:2.3:a:apache:httpclient:*:*:*:*:*:*:*:* Versions 4.3 – 4.3.5 Vulnerable ·Apache
Remediation
- Fix · GHSA-fmj5-wv96-r2ch org.apache.httpcomponents:httpclient (Maven) Fixed in 4.3.6 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix yet |
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat Virtualization 4 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5262
- 2026-10-03 Alias added: GHSA-fmj5-wv96-r2ch
References
Advisory 12
- http://svn.apache.org/viewvc?view=revision&revision=1626784
- https://jenkins.io/security/advisory/2018-02-26/
- https://bugzilla.redhat.com/show_bug.cgi?id=1261538
- FEDORA-2015-15590
- FEDORA-2015-15589
- https://issues.apache.org/jira/browse/HTTPCLIENT-1478
- FEDORA-2015-15588
- USN-2769-1
- openSUSE-SU-2020:1873
- openSUSE-SU-2020:1875
- https://nvd.nist.gov/vuln/detail/CVE-2015-5262
- https://github.com/advisories/GHSA-fmj5-wv96-r2ch
Other 8
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
- [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- https://jenkins.io/security/advisory/2018-02-26
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
Sources
- CVE-2015-5262 · CVE Program
- CVE-2015-5262 · NVD
- FIRST EPSS
- GHSA-fmj5-wv96-r2ch · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5262 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences