Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens…
Priority LOW 32CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264 and CWE-522.
Summary
Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens which might allow remote administrators to gain privileges and run scripts by using an API token of another user.
Why it matters now
EPSS 0.01491 74th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.625.2, 1.638Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.625.2 | 1.625.2 | Patch available | GHSA-x4m5-j4x4-4wjg |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.626 to before 1.638 | 1.638 | Patch available | GHSA-x4m5-j4x4-4wjg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.625.2 Fixed in 1.625.2 Patch available GHSA-x4m5-j4x4-4wjg
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.626 to before 1.638 Fixed in 1.638 Patch available GHSA-x4m5-j4x4-4wjg
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openshift:*:*:*:*:enterprise:*:*:* | up to 3.1 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* | up to 1.625.1 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* | up to 1.637 | Vulnerable | Jenkins |
- cpe:2.3:a:redhat:openshift:*:*:*:*:enterprise:*:*:* Versions up to 3.1 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 1.625.1 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.637 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-x4m5-j4x4-4wjg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.625.2 Advisory →
- Fix · GHSA-x4m5-j4x4-4wjg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.638 Advisory →
Red Hat 2 advisories
- RHSA-2016:0489 Released 2016-03-22 · Red Hat rating ImportantRed Hat OpenShift Enterprise 2.2.9 security, bug fix, and enhancement update
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.38.6.1-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 activemq-5.9.0-6.redhat.611454.el6op, activemq-client-5.9.0-6.redhat.611454.el6op, openshift-enterprise-release-2.2.9-1.el6op +7
- Red Hat OpenShift Enterprise Node 2.2 activemq-5.9.0-6.redhat.611454.el6op, activemq-client-5.9.0-6.redhat.611454.el6op, jenkins-1.625.3-1.el6op +23
- RHSA-2016:0070 Released 2016-01-26 · Red Hat rating ImportantRed Hat OpenShift Enterprise 3.1.1 bug fix and enhancement update
- Red Hat OpenShift Enterprise 3.1 atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-redistributable-3.1.1.6-1.git.0.b57e8bd.el7aos +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:0070 |
| Red Hat OpenShift Enterprise Client 2.2 | Fixed | RHSA-2016:0489 |
| Red Hat OpenShift Enterprise Infrastructure 2.2 | Fixed | RHSA-2016:0489 |
| Red Hat OpenShift Enterprise Node 2.2 | Fixed | RHSA-2016:0489 |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-5323
- 2026-10-03 Alias added: GHSA-x4m5-j4x4-4wjg
References
Sources
- CVE-2015-5323 · CVE Program
- CVE-2015-5323 · NVD
- FIRST EPSS
- GHSA-x4m5-j4x4-4wjg · GitHub Advisory Database · CC BY 4.0
- CVE-2015-5323 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences