Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for…
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the DataTables plugin 1.10.8 and earlier for jQuery allows remote attackers to inject arbitrary web script or HTML via the scripts parameter to media/unit_testing/templates/6776.php.
Why it matters now
EPSS 0.02679 85th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed datatables (npm): 1.10.10datatables/datatables (Packagist): 1.10.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | datatables (npm) | before 1.10.10 | 1.10.10 | Patch available | GHSA-4mv4-gmmf-q382 |
| — | datatables/datatables (Packagist) | before 1.10.10 | 1.10.10 | Patch available | GHSA-4mv4-gmmf-q382 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- datatables (npm) Vendor— Affected before 1.10.10 Fixed in 1.10.10 Patch available GHSA-4mv4-gmmf-q382
- datatables/datatables (Packagist) Vendor— Affected before 1.10.10 Fixed in 1.10.10 Patch available GHSA-4mv4-gmmf-q382
Remediation
- Fix · GHSA-4mv4-gmmf-q382 datatables (npm) Fixed in 1.10.10 Advisory →
- Fix · GHSA-4mv4-gmmf-q382 datatables/datatables (Packagist) Fixed in 1.10.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-6584
- 2026-10-03 Alias added: GHSA-4mv4-gmmf-q382
References
Other 8
- http://packetstormsecurity.com/files/133555/DataTables-1.10.8-Cross-Site-Scripting.html
- 20150910 DataTables Security Advisory - XSS Vulnerability - CVE-2015-6584
- https://github.com/DataTables/DataTables/issues/602
- https://github.com/DataTables/DataTablesSrc/commit/ccf86dc5982bd8e16d
- https://github.com/DataTables/DataTables
- https://github.com/DataTables/DataTablesSrc/commits/1.10.10?after=9780a3693572757d87bf70e48bd7555faf974f28+34&branch=1.10.10&qualified_name=refs%2Ftags%2F1.10.10
- https://www.netsparker.com/cve-2015-6384-xss-vulnerability-identified-in-datatables
- https://www.npmjs.com/advisories/5
More Sprymedia Datatables vulnerabilities
- TI-2025-10101 DataTables examples.php path traversal CVSS 4.0MEDIUM 6.9
- TI-2021-14853 Cross Site Scripting (XSS) vulnerability in the DataTables plug-in 1.9.2 for jQuery… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2015-6584 · CVE Program
- CVE-2015-6584 · NVD
- FIRST EPSS
- GHSA-4mv4-gmmf-q382 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences