Read the docs
TI-2015-05786 Aliases CVE-2015-6938GHSA-4vwq-x64q-j4cj

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py…

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.

Why it matters now

EPSS 0.02792 86th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed notebook (PyPI): 4.0.5ipython (PyPI): 3.2.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—notebook (PyPI)4.0.0 to before 4.0.54.0.5Patch availableGHSA-4vwq-x64q-j4cj
—ipython (PyPI)before 3.2.23.2.2Patch availableGHSA-4vwq-x64q-j4cj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • notebook (PyPI) Vendor— Affected 4.0.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-4vwq-x64q-j4cj
  • ipython (PyPI) Vendor— Affected before 3.2.2 Fixed in 3.2.2 Patch available GHSA-4vwq-x64q-j4cj

CPE configurations NVD · 11

CPEVersionsRoleVendor
cpe:2.3:a:jupyter:notebook:4.0.0:*:*:*:*:*:*:*4.0.0Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.1:*:*:*:*:*:*:*4.0.1Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.2:*:*:*:*:*:*:*4.0.2Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.3:*:*:*:*:*:*:*4.0.3Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.4:*:*:*:*:*:*:*4.0.4Vulnerablejupyterlab
cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:*21VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*22VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*23VulnerableFedoraproject
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*13.1VulnerableopenSUSE
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*13.2VulnerableopenSUSE
  • cpe:2.3:a:jupyter:notebook:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·jupyterlab
  • cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* Versions 21 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
Show 1 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:ipython:notebook:*:*:*:*:*:*:*:*up to 3.2.1Vulnerableipython
  • cpe:2.3:a:ipython:notebook:*:*:*:*:*:*:*:* Versions up to 3.2.1 Vulnerable ·ipython

Remediation

  • Fix · GHSA-4vwq-x64q-j4cj notebook (PyPI) Fixed in 4.0.5 Advisory →
  • Fix · GHSA-4vwq-x64q-j4cj ipython (PyPI) Fixed in 3.2.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-6938
  2. 2026-10-03 Alias added: GHSA-4vwq-x64q-j4cj

References

Sources