ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
Priority LOW 37CWE-90Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
ldapauth-fork before 2.3.3 allows remote attackers to perform LDAP injection attacks via a crafted username.
Why it matters now
EPSS 0.02137 82nd percentileScored 2026-11-07
Fix Fixed ldapauth-fork (npm): 2.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ldapauth-fork (npm) | before 2.3.3 | 2.3.3 | Patch available | GHSA-82mg-x548-gq3j |
| — | ldapauth (npm) | all versions | — | No fix listed | GHSA-82mg-x548-gq3j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ldapauth-fork (npm) Vendor— Affected before 2.3.3 Fixed in 2.3.3 Patch available GHSA-82mg-x548-gq3j
- ldapauth (npm) Vendor— Affected all versions Fixed in — No fix listed GHSA-82mg-x548-gq3j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ldapauth-fork_project:ldapauth-fork:*:*:*:*:*:node.js:*:* | before 2.3.3 | Vulnerable | Ldapauth-fork Project |
- cpe:2.3:a:ldapauth-fork_project:ldapauth-fork:*:*:*:*:*:node.js:*:* Versions before 2.3.3 Vulnerable ·Ldapauth-fork Project
Remediation
- Fix · GHSA-82mg-x548-gq3j ldapauth-fork (npm) Fixed in 2.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-7294
- 2026-10-03 Alias added: GHSA-82mg-x548-gq3j
References
Advisory 2
Other 6
- [oss-security] 20150921 Re: CVE request - ldapauth-fork versions < 2.3.3 are vulnerable to ldap injection.
- [oss-security] 20150918 Re: CVE request - ldapauth-fork versions < 2.3.3 are vulnerable to ldap injection.
- https://github.com/vesse/node-ldapauth-fork
- https://www.npmjs.com/advisories/18
- https://www.npmjs.com/advisories/19
- http://www.openwall.com/lists/oss-security/2015/09/18/4
Sources
- CVE-2015-7294 · CVE Program
- CVE-2015-7294 · NVD
- FIRST EPSS
- GHSA-82mg-x548-gq3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences