Read the docs
TI-2015-06101 Aliases CVE-2015-7337GHSA-92mr-v722-f48m

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5…

Priority LOW 35CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

Why it matters now

EPSS 0.02487 84th percentileScored 2026-11-07
Fix Fixed notebook (PyPI): 4.0.5ipython (PyPI): 3.2.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—notebook (PyPI)4.0.0 to before 4.0.54.0.5Patch availableGHSA-92mr-v722-f48m
—ipython (PyPI)before 3.2.23.2.2Patch availableGHSA-92mr-v722-f48m
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • notebook (PyPI) Vendor— Affected 4.0.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-92mr-v722-f48m
  • ipython (PyPI) Vendor— Affected before 3.2.2 Fixed in 3.2.2 Patch available GHSA-92mr-v722-f48m

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:ipython:notebook:*:*:*:*:*:*:*:*up to 3.2.1Vulnerableipython
cpe:2.3:a:jupyter:notebook:4.0.0:*:*:*:*:*:*:*4.0.0Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.1:*:*:*:*:*:*:*4.0.1Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.2:*:*:*:*:*:*:*4.0.2Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.3:*:*:*:*:*:*:*4.0.3Vulnerablejupyterlab
cpe:2.3:a:jupyter:notebook:4.0.4:*:*:*:*:*:*:*4.0.4Vulnerablejupyterlab
  • cpe:2.3:a:ipython:notebook:*:*:*:*:*:*:*:* Versions up to 3.2.1 Vulnerable ·ipython
  • cpe:2.3:a:jupyter:notebook:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.3:*:*:*:*:*:*:* Versions 4.0.3 Vulnerable ·jupyterlab
  • cpe:2.3:a:jupyter:notebook:4.0.4:*:*:*:*:*:*:* Versions 4.0.4 Vulnerable ·jupyterlab

Remediation

  • Fix · GHSA-92mr-v722-f48m notebook (PyPI) Fixed in 4.0.5 Advisory →
  • Fix · GHSA-92mr-v722-f48m ipython (PyPI) Fixed in 3.2.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-7337
  2. 2026-10-03 Alias added: GHSA-92mr-v722-f48m

References

Sources