The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote…
Priority CRITICAL 85CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-*.jar file and the "Groovy variant in 'ysoserial'".
Why it matters now
EPSS 0.91865 99th percentileScored 2026-11-07
Public exploit Yes 4 exploit referencesTagged by NVD and the CNA
Fix Fixed org.jenkins-ci.main:cli (Maven): 1.625.2, 1.638Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:cli (Maven) | before 1.625.2 | 1.625.2 | Patch available | GHSA-wfw7-6632-xcv2 |
| — | org.jenkins-ci.main:cli (Maven) | 1.626 to before 1.638 | 1.638 | Patch available | GHSA-wfw7-6632-xcv2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:cli (Maven) Vendor— Affected before 1.625.2 Fixed in 1.625.2 Patch available GHSA-wfw7-6632-xcv2
- org.jenkins-ci.main:cli (Maven) Vendor— Affected 1.626 to before 1.638 Fixed in 1.638 Patch available GHSA-wfw7-6632-xcv2
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openshift_container_platform:2.2:*:*:*:*:*:*:* | 2.2 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:3.1:*:*:*:*:*:*:* | 3.1 | Vulnerable | Red Hat |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* | before 1.625.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* | before 1.638 | Vulnerable | Jenkins |
- cpe:2.3:a:redhat:openshift_container_platform:2.2:*:*:*:*:*:*:* Versions 2.2 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·Red Hat
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions before 1.625.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions before 1.638 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-wfw7-6632-xcv2 org.jenkins-ci.main:cli (Maven) Fixed in 1.625.2 Advisory →
- Fix · GHSA-wfw7-6632-xcv2 org.jenkins-ci.main:cli (Maven) Fixed in 1.638 Advisory →
Red Hat 2 advisories
- RHSA-2016:0489 Released 2016-03-22 · Red Hat rating ImportantRed Hat OpenShift Enterprise 2.2.9 security, bug fix, and enhancement update
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.38.6.1-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 activemq-5.9.0-6.redhat.611454.el6op, activemq-client-5.9.0-6.redhat.611454.el6op, openshift-enterprise-release-2.2.9-1.el6op +7
- Red Hat OpenShift Enterprise Node 2.2 activemq-5.9.0-6.redhat.611454.el6op, activemq-client-5.9.0-6.redhat.611454.el6op, jenkins-1.625.3-1.el6op +23
- RHSA-2016:0070 Released 2016-01-26 · Red Hat rating ImportantRed Hat OpenShift Enterprise 3.1.1 bug fix and enhancement update
- Red Hat OpenShift Enterprise 3.1 atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-redistributable-3.1.1.6-1.git.0.b57e8bd.el7aos +47
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:0070 |
| Red Hat OpenShift Enterprise Client 2.2 | Fixed | RHSA-2016:0489 |
| Red Hat OpenShift Enterprise Infrastructure 2.2 | Fixed | RHSA-2016:0489 |
| Red Hat OpenShift Enterprise Node 2.2 | Fixed | RHSA-2016:0489 |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8103
- 2026-10-03 Alias added: GHSA-wfw7-6632-xcv2
- 2026-10-24 Priority changed: HIGH → CRITICAL
References
Exploit 4
- http://packetstormsecurity.com/files/134805/Jenkins-CLI-RMI-Java-Deserialization.html
- https://jenkins-ci.org/content/mitigating-unauthenticated-remote-code-execution-0-day-jenkins-cli
- 38983
- http://foxglovesecurity.com/2015/11/06/what-do-weblogic-websphere-jboss-jenkins-opennms-and-your-application-have-in-common-this-vulnerability/#jenkins
Advisory 4
Other 9
- [oss-security] 20151118 Re: CVE request: Jenkins remote code execution vulnerability due to unsafe deserialization
- [oss-security] 20151118 Re: CVE request: Jenkins remote code execution vulnerability due to unsafe deserialization
- [oss-security] 20151109 CVE request: Jenkins remote code execution vulnerability due to unsafe deserialization
- [oss-security] 20151118 Re: CVE request: Jenkins remote code execution vulnerability due to unsafe deserialization
- https://github.com/jenkinsci/jenkins/commit/5bd9b55a2a3249939fd78c501b8959a804c1164b
- https://github.com/jenkinsci/jenkins/commit/b4193d1132089286ebeaf9d8872c839ad473329c
- https://github.com/jenkinsci/jenkins
- https://web.archive.org/web/20151225025917/http://www.securityfocus.com/bid/77636
- https://www.exploit-db.com/exploits/38983
Sources
- CVE-2015-8103 · CVE Program
- CVE-2015-8103 · NVD
- FIRST EPSS
- GHSA-wfw7-6632-xcv2 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8103 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences