Multiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to…
Priority LOW 27CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Multiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to inject arbitrary SMTP commands via CRLF sequences in an (1) email address to the validateAddress function in class.phpmailer.php or (2) SMTP command to the sendCommand function in class.smtp.php, a different vulnerability than CVE-2012-0796.
Why it matters now
EPSS 0.01988 80th percentileScored 2026-11-07
Fix Fixed phpmailer/phpmailer (Packagist): 5.2.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmailer/phpmailer (Packagist) | 5.0.0 to before 5.2.14 | 5.2.14 | Patch available | GHSA-738m-f33v-qc2r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmailer/phpmailer (Packagist) Vendor— Affected 5.0.0 to before 5.2.14 Fixed in 5.2.14 Patch available GHSA-738m-f33v-qc2r
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* | up to 5.2.13 | Vulnerable | Phpmailer Project |
- cpe:2.3:o:debian:debian_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* Versions up to 5.2.13 Vulnerable ·Phpmailer Project
Remediation
- Fix · GHSA-738m-f33v-qc2r phpmailer/phpmailer (Packagist) Fixed in 5.2.14 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8476
- 2026-10-03 Alias added: GHSA-738m-f33v-qc2r
References
Advisory 5
Other 5
- https://github.com/PHPMailer/PHPMailer/commit/6687a96a18b8f12148881e4ddde795ae477284b0
- [oss-security] 20151204 Re: CVE Request: PHPMailer Message Injection Vulnerability
- [oss-security] 20151204 CVE Request: PHPMailer Message Injection Vulnerability
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-738m-f33v-qc2r
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2015-8476.yaml
Sources
- CVE-2015-8476 · CVE Program
- CVE-2015-8476 · NVD
- FIRST EPSS
- GHSA-738m-f33v-qc2r · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8476 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences