Cross-site scripting (XSS) vulnerability in Redmine before 2.6.2 allows remote attackers…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Redmine before 2.6.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving flash message rendering.
Why it matters now
EPSS 0.01509 74th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8477
- 2026-10-03 Alias added: GHSA-2m2q-2ghr-grp8
References
Advisory 4
- https://www.redmine.org/projects/redmine/repository/entry/tags/2.6.2/doc/CHANGELOG
- [oss-security] 20151205 Re: CVE request: Redmine: cross-site scripting vulnerability fixed in 3.0.0 and 2.6.2
- [oss-security] 20151205 Re: CVE request: Redmine: cross-site scripting vulnerability fixed in 3.0.0 and 2.6.2
- http://www.redmine.org/projects/redmine/wiki/Security_Advisories
More Redmine vulnerabilities
- TI-2011-04243 Unspecified vulnerability in the bazaar repository adapter in Redmine 0.9.x and 1.0.x… CVSS 2.0HIGH 7.5
- TI-2021-10704 Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the… CVSS 3.1CRITICAL 9.8
- TI-2017-13235 Redmine before 3.2.9, 3.3.x before 3.3.6, and 3.4.x before 3.4.4 does not block the… CVSS 3.0HIGH 8.8
- TI-2017-11378 Redmine before 3.2.6 and 3.3.x before 3.3.3 mishandles the rendering of wiki links, which… CVSS 3.0HIGH 7.5
- TI-2017-11377 Redmine before 3.2.6 and 3.3.x before 3.3.3 mishandles Time Entry rendering in activity… CVSS 3.0HIGH 7.5
- TI-2017-11373 In Redmine before 3.2.6 and 3.3.x before 3.3.3, remote attackers can obtain sensitive… CVSS 3.0HIGH 7.5
Sources
- CVE-2015-8477 · CVE Program
- CVE-2015-8477 · NVD
- FIRST EPSS
- GHSA-2m2q-2ghr-grp8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences