The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2…
Priority MEDIUM 48CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 7 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.
Summary
The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.
Why it matters now
EPSS 0.06718 93rd percentileScored 2026-11-07
Fix Partial Pygments (PyPI): 2.1Red Hat: 7 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Pygments (PyPI) | 1.2.2 to before 2.1 | 2.1 | Patch available | GHSA-fff8-4w9p-7v76 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Pygments (PyPI) Vendor— Affected 1.2.2 to before 2.1 Fixed in 2.1 Patch available GHSA-fff8-4w9p-7v76
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* | 15.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* | 15.10 | Vulnerable | Canonical |
| cpe:2.3:a:pygments:pygments:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:1.3:*:*:*:*:*:*:* | 1.3 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:1.5:*:*:*:*:*:*:* | 1.5 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:1.6:*:*:*:*:*:*:* | 1.6 | Vulnerable | Pygments |
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* Versions 15.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* Versions 15.10 Vulnerable ·Canonical
- cpe:2.3:a:pygments:pygments:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:1.3:*:*:*:*:*:*:* Versions 1.3 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:1.5:*:*:*:*:*:*:* Versions 1.5 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·Pygments
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pygments:pygments:1.6:rc1:*:*:*:*:*:* | 1.6 rc1 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:2.0:*:*:*:*:*:*:* | 2.0 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:2.0:rc1:*:*:*:*:*:* | 2.0 rc1 | Vulnerable | Pygments |
| cpe:2.3:a:pygments:pygments:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Pygments |
- cpe:2.3:a:pygments:pygments:1.6:rc1:*:*:*:*:*:* Versions 1.6 rc1 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:2.0:rc1:*:*:*:*:*:* Versions 2.0 rc1 Vulnerable ·Pygments
- cpe:2.3:a:pygments:pygments:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Pygments
Remediation
- Fix · GHSA-fff8-4w9p-7v76 Pygments (PyPI) Fixed in 2.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.2 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse) | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8557
- 2026-10-03 Alias added: GHSA-fff8-4w9p-7v76
References
Advisory 6
Other 8
- http://packetstormsecurity.com/files/133823/Pygments-FontManager._get_nix_font_path-Shell-Injection.html
- [oss-security] 20151214 CVE request: Shell Injection in Pygments FontManager._get_nix_font_path
- [oss-security] 20151214 Re: CVE request: Shell Injection in Pygments FontManager._get_nix_font_path
- 20151001 Shell Injection in Pygments FontManager._get_nix_font_path
- http://www.oracle.com/technetwork/topics/security/bulletinjan2016-2867206.html
- https://github.com/pygments/pygments/commit/db6dd826f8624179e563aaded391efe824462f51
- https://github.com/pygments/pygments
- https://github.com/pypa/advisory-database/tree/main/vulns/pygments/PYSEC-2016-32.yaml
Sources
- CVE-2015-8557 · CVE Program
- CVE-2015-8557 · NVD
- FIRST EPSS
- GHSA-fff8-4w9p-7v76 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8557 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences