Read the docs
TI-2015-07251 Aliases CVE-2015-8806GHSA-7hp2-xwpj-95jq

dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer…

Priority MEDIUM 41CWE-125Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-125 and the CVSS impact.

Summary

dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an unexpected character immediately after the "<!DOCTYPE html" substring in a crafted HTML document.

Why it matters now

EPSS 0.04964 92nd percentileScored 2026-11-07
Fix Fixed nokogiri (RubyGems): 1.6.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—nokogiri (RubyGems)1.6.0 to before 1.6.81.6.8Patch availableGHSA-7hp2-xwpj-95jq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • nokogiri (RubyGems) Vendor— Affected 1.6.0 to before 1.6.8 Fixed in 1.6.8 Patch available GHSA-7hp2-xwpj-95jq

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:xmlsoft:libxml2:*:*:*:*:*:*:*:*before 2.9.4Vulnerablexmlsoft
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:*12.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:*14.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:*15.10VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*16.04VulnerableCanonical
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
  • cpe:2.3:a:xmlsoft:libxml2:*:*:*:*:*:*:*:* Versions before 2.9.4 Vulnerable ·xmlsoft
  • cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* Versions 12.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* Versions 15.10 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-7hp2-xwpj-95jq nokogiri (RubyGems) Fixed in 1.6.8 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 3 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-8806
  2. 2026-10-03 Alias added: GHSA-7hp2-xwpj-95jq

References

Sources