Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for…
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.
Why it matters now
EPSS 0.02477 84th percentileScored 2026-11-07
Fix Fixed serve-index (npm): 1.6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | serve-index (npm) | before 1.6.3 | 1.6.3 | Patch available | GHSA-v633-x5vv-hqwc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- serve-index (npm) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-v633-x5vv-hqwc
Remediation
- Fix · GHSA-v633-x5vv-hqwc serve-index (npm) Fixed in 1.6.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8856
- 2026-10-03 Alias added: GHSA-v633-x5vv-hqwc
References
Advisory 2
Sources
- CVE-2015-8856 · CVE Program
- CVE-2015-8856 · NVD
- FIRST EPSS
- GHSA-v633-x5vv-hqwc · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8856 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences