The handlebars package before 4.0.0 for Node.js allows remote attackers to conduct…
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The handlebars package before 4.0.0 for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging a template with an attribute that is not quoted.
Why it matters now
EPSS 0.02612 85th percentileScored 2026-11-07
Fix Fixed handlebars (npm): 4.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | handlebars (npm) | before 4.0.0 | 4.0.0 | Patch available | GHSA-9prh-257w-9277 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- handlebars (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-9prh-257w-9277
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:handlebars.js_project:handlebars.js:*:*:*:*:*:node.js:*:* | before 4.0.0 | Vulnerable | Handlebars.js Project |
- cpe:2.3:a:handlebars.js_project:handlebars.js:*:*:*:*:*:node.js:*:* Versions before 4.0.0 Vulnerable ·Handlebars.js Project
Remediation
- Fix · GHSA-9prh-257w-9277 handlebars (npm) Fixed in 4.0.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8861
- 2026-10-03 Alias added: GHSA-9prh-257w-9277
References
Advisory 4
More Handlebars.js Project Handlebars.js vulnerabilities
- TI-2019-14365 Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-8861 · CVE Program
- CVE-2015-8861 · NVD
- FIRST EPSS
- GHSA-9prh-257w-9277 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8861 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences