The openssl_random_pseudo_bytes function in ext/openssl/openssl.c in PHP before 5.4.44…
Priority MEDIUM 40CWE-310Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 7 fixed, 4 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.
Summary
The openssl_random_pseudo_bytes function in ext/openssl/openssl.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 incorrectly relies on the deprecated RAND_pseudo_bytes function, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via unspecified vectors.
Why it matters now
EPSS 0.04353 91st percentileScored 2026-11-07
Fix Partial Red Hat: 1 advisoryRed Hat: 7 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 5.4.0 to before 5.4.44; 5.5.0 to before 5.5.28; 5.6.0 to before 5.6.12 | Vulnerable | PHP |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* | 15.10 | Vulnerable | Canonical |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 5.4.0 to before 5.4.44; 5.5.0 to before 5.5.28; 5.6.0 to before 5.6.12 Vulnerable ·PHP
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:* Versions 15.10 Vulnerable ·Canonical
Remediation
Red Hat 1 advisory
- RHSA-2016:2750 Released 2016-11-15 · Red Hat rating Moderaterh-php56 security, bug fix, and enhancement update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-php56-2.3-1.el6, rh-php56-php-5.6.25-1.el6, rh-php56-php-bcmath-5.6.25-1.el6 +30
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-php56-2.3-1.el7, rh-php56-php-5.6.25-1.el7, rh-php56-php-bcmath-5.6.25-1.el7 +28
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-php56-2.3-1.el6, rh-php56-php-5.6.25-1.el6, rh-php56-php-bcmath-5.6.25-1.el6 +30
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2) rh-php56-2.3-1.el7, rh-php56-php-5.6.25-1.el7, rh-php56-php-bcmath-5.6.25-1.el7 +28
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) rh-php56-2.3-1.el7, rh-php56-php-5.6.25-1.el7, rh-php56-php-bcmath-5.6.25-1.el7 +28
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-php56-2.3-1.el6, rh-php56-php-5.6.25-1.el6, rh-php56-php-bcmath-5.6.25-1.el6 +30
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-php56-2.3-1.el7, rh-php56-php-5.6.25-1.el7, rh-php56-php-bcmath-5.6.25-1.el7 +28
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2016:2750 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2016:2750 |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-8867
- 2026-10-03 Alias added: GHSA-33q5-mhvx-53mf
References
Advisory 11
- USN-2952-1
- http://www.php.net/ChangeLog-7.php
- https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1534203
- RHSA-2016:2750
- USN-2952-2
- https://bugs.php.net/bug.php?id=70014
- http://www.php.net/ChangeLog-5.php
- openSUSE-SU-2016:1274
- SUSE-SU-2016:1277
- [oss-security] 20160423 Re: CVE request: PHP issues fixed in 7.0.5, 5.6.20 and 5.5.34 releases
- openSUSE-SU-2016:1373
Sources
- CVE-2015-8867 · CVE Program
- CVE-2015-8867 · NVD
- FIRST EPSS
- GHSA-33q5-mhvx-53mf · GitHub Advisory Database · CC BY 4.0
- CVE-2015-8867 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences