SQL injection in HackerOne mysql node module
Priority MEDIUM 47CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Keys of objects in mysql node module v2.0.0-alpha7 and earlier are not escaped with `mysql.escape()` which could lead to SQL Injection.
Why it matters now
EPSS 0.02426 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mysql (npm): 2.0.0-alpha8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | mysql node module | up to v2.0.0-alpha7 | — | No fix listed | CNA |
| — | mysql (npm) | before 2.0.0-alpha8 | 2.0.0-alpha8 | Patch available | GHSA-fvq6-55gv-jx9f |
- mysql node module VendorHackerOne Affected up to v2.0.0-alpha7 Fixed in — No fix listed CNA
- mysql (npm) Vendor— Affected before 2.0.0-alpha8 Fixed in 2.0.0-alpha8 Patch available GHSA-fvq6-55gv-jx9f
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mysqljs:mysql:*:*:*:*:*:node.js:*:* | up to 0.9.6 | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:alpha:*:*:*:node.js:*:* | 2.0.0 alpha | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:alpha2:*:*:*:node.js:*:* | 2.0.0 alpha2 | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:alpha3:*:*:*:node.js:*:* | 2.0.0 alpha3 | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:alpha4:*:*:*:node.js:*:* | 2.0.0 alpha4 | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:alpha7:*:*:*:node.js:*:* | 2.0.0 alpha7 | Vulnerable | Mysqljs |
| cpe:2.3:a:mysqljs:mysql:2.0.0:preview:*:*:*:node.js:*:* | 2.0.0 preview | Vulnerable | Mysqljs |
- cpe:2.3:a:mysqljs:mysql:*:*:*:*:*:node.js:*:* Versions up to 0.9.6 Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:alpha:*:*:*:node.js:*:* Versions 2.0.0 alpha Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:alpha2:*:*:*:node.js:*:* Versions 2.0.0 alpha2 Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:alpha3:*:*:*:node.js:*:* Versions 2.0.0 alpha3 Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:alpha4:*:*:*:node.js:*:* Versions 2.0.0 alpha4 Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:alpha7:*:*:*:node.js:*:* Versions 2.0.0 alpha7 Vulnerable ·Mysqljs
- cpe:2.3:a:mysqljs:mysql:2.0.0:preview:*:*:*:node.js:*:* Versions 2.0.0 preview Vulnerable ·Mysqljs
Remediation
- Fix · GHSA-fvq6-55gv-jx9f mysql (npm) Fixed in 2.0.0-alpha8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-9244
- 2026-10-03 Alias added: GHSA-fvq6-55gv-jx9f
References
Sources
- CVE-2015-9244 · CVE Program
- CVE-2015-9244 · NVD
- FIRST EPSS
- GHSA-fvq6-55gv-jx9f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences