nterchange code_caller_controller.php getContent code injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The patch is named fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | nterchange | 4.0; 4.1 | — | No fix listed | CNA |
| — | nonfiction/nterchange (Packagist) | before 4.1.1 | 4.1.1 | Patch available | GHSA-cp2p-6xh4-jmcp |
- nterchange Vendor— Affected 4.0; 4.1 Fixed in — No fix listed CNA
- nonfiction/nterchange (Packagist) Vendor— Affected before 4.1.1 Fixed in 4.1.1 Patch available GHSA-cp2p-6xh4-jmcp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nonfiction:nterchange:*:*:*:*:*:*:*:* | before 4.1.1 | Vulnerable | Nonfiction |
- cpe:2.3:a:nonfiction:nterchange:*:*:*:*:*:*:*:* Versions before 4.1.1 Vulnerable ·Nonfiction
Remediation
- Fix · GHSA-cp2p-6xh4-jmcp nonfiction/nterchange (Packagist) Fixed in 4.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10009
- 2026-10-03 Alias added: GHSA-cp2p-6xh4-jmcp
References
Sources
- CVE-2015-10009 · CVE Program
- CVE-2015-10009 · NVD
- FIRST EPSS
- GHSA-cp2p-6xh4-jmcp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences