SUKOHI Surpass Surpass.php pathname traversal
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUKOHI | Surpass | all versions | — | No fix listed | CNA |
| — | sukohi/surpass (Packagist) | before 1.0.0 | 1.0.0 | Patch available | GHSA-c9pw-f4wp-22jr |
- Surpass VendorSUKOHI Affected all versions Fixed in — No fix listed CNA
- sukohi/surpass (Packagist) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-c9pw-f4wp-22jr
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:surpass_project:surpass:*:*:*:*:*:*:*:* | before 1.0.0 | Vulnerable | Surpass Project |
- cpe:2.3:a:surpass_project:surpass:*:*:*:*:*:*:*:* Versions before 1.0.0 Vulnerable ·Surpass Project
Remediation
- Fix · GHSA-c9pw-f4wp-22jr sukohi/surpass (Packagist) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10030
- 2026-10-03 Alias added: GHSA-c9pw-f4wp-22jr
References
Sources
- CVE-2015-10030 · CVE Program
- CVE-2015-10030 · NVD
- FIRST EPSS
- GHSA-c9pw-f4wp-22jr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences