Zarthus IRC Twitter Announcer Bot twitter_announcer.rb get_tweets command injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
A vulnerability, which was classified as critical, was found in Zarthus IRC Twitter Announcer Bot up to 1.1.0. This affects the function get_tweets of the file lib/twitterbot/plugins/twitter_announcer.rb. The manipulation of the argument tweet leads to command injection. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.1.1 is able to address this issue. The patch is named 6b1941b7fc2c70e1f40981b43c84a2c20cc12bd3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-223383.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zarthus | IRC Twitter Announcer Bot | 1.0; 1.1 | — | No fix listed | CNA |
- IRC Twitter Announcer Bot VendorZarthus Affected 1.0; 1.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:irc_twitter_announcer_bot_project:irc_twitter_announcer_bot:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Irc Twitter Announcer Bot Project |
- cpe:2.3:a:irc_twitter_announcer_bot_project:irc_twitter_announcer_bot:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Irc Twitter Announcer Bot Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10096
- 2026-10-03 Alias added: GHSA-hmv7-wgxc-xvjj
References
Sources
- CVE-2015-10096 · CVE Program
- CVE-2015-10096 · NVD
- FIRST EPSS
- GHSA-hmv7-wgxc-xvjj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences