Read the docs
TI-2015-08028 Aliases CVE-2015-10100GHSA-587p-pvvj-3ghc

Dynamic Widgets Plugin dynwid_class.php sql injection

Priority MEDIUM 44CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

A vulnerability, which was classified as critical, has been found in Dynamic Widgets Plugin up to 1.5.10 on WordPress. This issue affects some unknown processing of the file classes/dynwid_class.php. The manipulation leads to sql injection. The attack may be initiated remotely. Upgrading to version 1.5.11 is able to address this issue. The identifier of the patch is d0a19c6efcdc86d7093b369bc9e29a0629e57795. It is recommended to upgrade the affected component. The identifier VDB-225353 was assigned to this vulnerability.

Why it matters now

EPSS 0.01054 64th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Dynamic Widgets Plugin1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4; 1.5.5; 1.5.6; 1.5.7; 1.5.8; 1.5.9; 1.5.10—No fix listedCNA
  • Dynamic Widgets Plugin Vendor— Affected 1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4; 1.5.5; 1.5.6; 1.5.7; 1.5.8; 1.5.9; 1.5.10 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vivwebsolutions:dynamic_widgets:*:*:*:*:*:wordpress:*:*before 1.5.11VulnerableVivwebsolutions
  • cpe:2.3:a:vivwebsolutions:dynamic_widgets:*:*:*:*:*:wordpress:*:* Versions before 1.5.11 Vulnerable ·Vivwebsolutions

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-10100
  2. 2026-10-03 Alias added: GHSA-587p-pvvj-3ghc

References

  • TI-2024-34583 WordPress Dynamic Widgets plugin <= 1.6.4 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
  • TI-2015-07814 The dynamic-widgets plugin before 1.5.11 for WordPress has CSRF with resultant XSS via… CVSS 3.1MEDIUM 6.5
  • TI-2015-07813 The dynamic-widgets plugin before 1.5.11 for WordPress has XSS via the… CVSS 3.1MEDIUM 5.4

Sources