Google Analytics Top Content Widget Plugin class-tgm-plugin-activation.php cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability classified as problematic was found in Google Analytics Top Content Widget Plugin up to 1.5.6 on WordPress. Affected by this vulnerability is an unknown functionality of the file class-tgm-plugin-activation.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.5.7 is able to address this issue. The identifier of the patch is 25bb1dea113716200a6f0f3135801d84a7a65540. It is recommended to upgrade the affected component. The identifier VDB-226117 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Google Analytics Top Content Widget Plugin | 1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4; 1.5.5; 1.5.6 | — | No fix listed | CNA |
- Google Analytics Top Content Widget Plugin Vendor— Affected 1.5.0; 1.5.1; 1.5.2; 1.5.3; 1.5.4; 1.5.5; 1.5.6 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google_analytics_top_content_widget_project:google_analytics_top_content_widget:*:*:*:*:*:wordpress:*:* | before 1.5.7 | Vulnerable | Google Analytics Top Content Widget Project |
- cpe:2.3:a:google_analytics_top_content_widget_project:google_analytics_top_content_widget:*:*:*:*:*:wordpress:*:* Versions before 1.5.7 Vulnerable ·Google Analytics Top Content Widget Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10101
- 2026-10-03 Alias added: GHSA-qq3j-6wh5-pqcg
References
Sources
- CVE-2015-10101 · CVE Program
- CVE-2015-10101 · NVD
- FIRST EPSS
- GHSA-qq3j-6wh5-pqcg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences