Most Popular Posts Widget Plugin functions.php show_views sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability was found in Most Popular Posts Widget Plugin up to 0.8 on WordPress. It has been classified as critical. Affected is the function add_views/show_views of the file functions.php. The manipulation leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 0.9 is able to address this issue. The patch is identified as a99667d11ac8d320006909387b100e9a8b5c12e1. It is recommended to upgrade the affected component. VDB-241026 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Most Popular Posts Widget Plugin | 0.1; 0.2; 0.3; 0.4; 0.5; 0.6; 0.7; 0.8 | — | No fix listed | CNA |
- Most Popular Posts Widget Plugin Vendor— Affected 0.1; 0.2; 0.3; 0.4; 0.5; 0.6; 0.7; 0.8 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10124
- 2026-10-03 Alias added: GHSA-8fpf-jxpx-6gf6
References
Sources
- CVE-2015-10124 · CVE Program
- CVE-2015-10124 · NVD
- FIRST EPSS
- GHSA-8fpf-jxpx-6gf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences