Path traversal in Aspose Doc Exporter WordPress plugin lets attackers read files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
The Aspose Doc Exporter plugin for WordPress before 2.0 contains a path traversal flaw (CWE-22) in its download handler, which passes unsanitized paths to readfile(). An unauthenticated remote attacker can send GET requests with crafted file path values to retrieve arbitrary files, such as the wp-config.php file that holds database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-23, and a public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Aspose Doc Exporter plugin for WordPress before 2.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files by passing unsanitized paths to readfile(). Attackers can send GET requests to aspose_doc_exporter_download.php with the 'file' parameter set to values like ../../../wp-config.php to retrieve database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-23.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update Aspose Doc Exporter to version 2.0 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Aspose Doc Exporter (Aspose) Fixed in 2.0
Timeline
- 2026-10-20 Threatist record created from CVE-2015-20123
- 2026-10-21 Alias added: GHSA-fv35-wmpq-m6x4
- 2026-10-22 Priority changed: MEDIUM → LOW
- 2026-10-27 CISA SSVC decision points changed
- 2026-10-27 Priority changed: LOW → HIGH
References
Exploit 2
Advisory 1
More Aspose vulnerabilities
- TI-2015-08114 Path traversal in Aspose Importer & Exporter WordPress plugin CVSS 4.0HIGH 8.7
- TI-2019-03528 Use after free in Talos Aspose CVSS 3.1CRITICAL 9.8
- TI-2019-03527 Use after free in Talos Aspose CVSS 3.1CRITICAL 9.8
- TI-2019-03504 Stack-based buffer overflow in Aspose CVSS 3.1HIGH 8.8
- TI-2019-03496 Out-of-bounds read in Aspose CVSS 3.1HIGH 8.8
- TI-2019-03495 Out-of-bounds read in Aspose CVSS 3.1HIGH 8.8
Sources
- CVE-2015-20123 · CVE Program
- CVE-2015-20123 · NVD
- FIRST EPSS
- GHSA-fv35-wmpq-m6x4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences