Reflected cross-site scripting in Netsweeper via view_server_log.php
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Netsweeper before 4.0.11 and from 4.1.0 before 4.1.5 contains a reflected cross-site scripting flaw in the webadmin/reporter/view_server_log.php page. The log request parameter is written into the HTML response without output encoding, which is CWE-79. A remote attacker can craft a malicious URL and induce a user to open it, running JavaScript in the victim's browser session on the Netsweeper web administration interface. Shadowserver Foundation first observed exploitation evidence on 2023-10-19, and a public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
Netsweeper before 4.0.11 and 4.1.0 before 4.1.5 contains a reflected cross-site scripting vulnerability in webadmin/reporter/view_server_log.php that allows remote attackers to execute arbitrary JavaScript by injecting malicious code through the log request parameter, which is reflected into the HTML response without output encoding. Attackers can craft a malicious URL and induce a user to request it, resulting in arbitrary JavaScript execution within the victim's browser session against the Netsweeper web administration interface. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Netsweeper | Netsweeper | before 4.0.11; 4.1.0 to before 4.1.5 | 4.0.11, 4.1.5 | Patch available | CNA |
- Netsweeper VendorNetsweeper Affected before 4.0.11; 4.1.0 to before 4.1.5 Fixed in 4.0.11, 4.1.5 Patch available CNA
Remediation
Upgrade Netsweeper to 4.0.11 or 4.1.5, which fix the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA Netsweeper (Netsweeper) Fixed in 4.0.11, 4.1.5
Timeline
- 2026-10-30 Threatist record created from CVE-2015-20130
- 2026-10-30 Alias added: GHSA-p77p-6fr4-6cww
- 2026-11-04 CISA SSVC decision points changed
- 2026-11-04 Priority changed: LOW → MEDIUM
References
Exploit 2
More Netsweeper vulnerabilities
- TI-2020-10347 Netsweeper through 6.4.3 allows unauthenticated remote code execution because… CVSS 3.1CRITICAL 9.8
- TI-2014-07809 The Client Filter Admin portal in Netsweeper before 3.1.10, 4.0.x before 4.0.9, and 4.1.x… CVSS 3.0CRITICAL 9.8
- TI-2014-07805 The Web Panel in Netsweeper before 4.0.5 has a default password of branding for the… CVSS 3.1CRITICAL 9.8
- TI-2014-07802 Netsweeper before 4.0.5 allows remote attackers to bypass authentication and create… CVSS 3.0CRITICAL 9.8
- TI-2014-07803 SQL injection vulnerability in remotereporter/load_logfiles.php in Netsweeper before… CVSS 3.1CRITICAL 9.8
- TI-2014-07804 Multiple SQL injection vulnerabilities in Netsweeper before 2.6.29.10 allow remote… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-20130 · CVE Program
- CVE-2015-20130 · NVD
- FIRST EPSS
- GHSA-p77p-6fr4-6cww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences