Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before…
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.
Why it matters now
EPSS 0.07157 94th percentileScored 2026-11-07
Fix Fixed activemodel (RubyGems): 4.1.14.1, 4.2.5.1Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | activemodel (RubyGems) | 4.1.0 to before 4.1.14.1 | 4.1.14.1 | Patch available | GHSA-543v-gj2c-r3ch |
| — | activemodel (RubyGems) | 4.2.0 to before 4.2.5.1 | 4.2.5.1 | Patch available | GHSA-543v-gj2c-r3ch |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- activemodel (RubyGems) Vendor— Affected 4.1.0 to before 4.1.14.1 Fixed in 4.1.14.1 Patch available GHSA-543v-gj2c-r3ch
- activemodel (RubyGems) Vendor— Affected 4.2.0 to before 4.2.5.1 Fixed in 4.2.5.1 Patch available GHSA-543v-gj2c-r3ch
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | 4.1.0 to before 4.1.14.1; 4.2.0 to before 4.2.5.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:5.0.0:beta1:*:*:*:*:*:* | 5.0.0 beta1 | Vulnerable | Rails |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* | 22 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* | 23 | Vulnerable | Fedoraproject |
| cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* | 42.1 | Vulnerable | openSUSE |
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.14.1; 4.2.0 to before 4.2.5.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:5.0.0:beta1:*:*:*:*:*:* Versions 5.0.0 beta1 Vulnerable ·Rails
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
- cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-543v-gj2c-r3ch activemodel (RubyGems) Fixed in 4.1.14.1 Advisory →
- Fix · GHSA-543v-gj2c-r3ch activemodel (RubyGems) Fixed in 4.2.5.1 Advisory →
Red Hat 1 advisory
- RHSA-2016:0296 Released 2016-02-24 · Red Hat rating Importantrh-ror41 security update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-ror41-rubygem-actionpack-1:4.1.5-3.el6, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el6, rh-ror41-rubygem-actionview-4.1.5-4.el6 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-ror41-rubygem-actionpack-1:4.1.5-3.el7, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el7, rh-ror41-rubygem-actionview-4.1.5-4.el7 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.6) rh-ror41-rubygem-actionpack-1:4.1.5-3.el6, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el6, rh-ror41-rubygem-actionview-4.1.5-4.el6 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-ror41-rubygem-actionpack-1:4.1.5-3.el6, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el6, rh-ror41-rubygem-actionview-4.1.5-4.el6 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.1) rh-ror41-rubygem-actionpack-1:4.1.5-3.el7, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el7, rh-ror41-rubygem-actionview-4.1.5-4.el7 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2) rh-ror41-rubygem-actionpack-1:4.1.5-3.el7, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el7, rh-ror41-rubygem-actionview-4.1.5-4.el7 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-ror41-rubygem-actionpack-1:4.1.5-3.el6, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el6, rh-ror41-rubygem-actionview-4.1.5-4.el6 +6
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-ror41-rubygem-actionpack-1:4.1.5-3.el7, rh-ror41-rubygem-actionpack-doc-1:4.1.5-3.el7, rh-ror41-rubygem-actionview-4.1.5-4.el7 +6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.6) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.1) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.2) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2016:0296 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2016:0296 |
Not affected: 4 products
- CloudForms Management Engine 5
- OpenStack Foreman
- Red Hat Software Collections
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0753
- 2026-10-03 Alias added: GHSA-543v-gj2c-r3ch
References
Advisory 11
- [oss-security] 20160125 [CVE-2016-0753] Possible Input Validation Circumvention in Active Model
- openSUSE-SU-2016:0372
- FEDORA-2016-94e71ee673
- FEDORA-2016-73fe05d878
- FEDORA-2016-cc465a34df
- SUSE-SU-2016:1146
- DSA-3464
- RHSA-2016:0296
- FEDORA-2016-eb4d6e8aab
- FEDORA-2016-cb30088b06
- https://nvd.nist.gov/vuln/detail/CVE-2016-0753
Other 7
- [ruby-security-ann] 20160125 [CVE-2016-0753] Possible Input Validation Circumvention in Active Model
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activemodel/CVE-2016-0753.yml
- https://groups.google.com/forum/#!topic/rubyonrails-security/6jQVC1geukQ
- https://web.archive.org/web/20160405205300/http://www.securitytracker.com/id/1034816
- https://web.archive.org/web/20200228000230/http://www.securityfocus.com/bid/82247
- https://web.archive.org/web/20210613054843/https://groups.google.com/forum/message/raw?msg=ruby-security-ann/6jQVC1geukQ/3Iy0GU1ZEgAJ
Sources
- CVE-2016-0753 · CVE Program
- CVE-2016-0753 · NVD
- FIRST EPSS
- GHSA-543v-gj2c-r3ch · GitHub Advisory Database · CC BY 4.0
- CVE-2016-0753 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences