PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission…
Priority LOW 31CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.
Why it matters now
EPSS 0.00933 60th percentileScored 2026-11-07
Fix Fixed postgresql:pljava-public (Maven): 1.5.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | postgresql:pljava-public (Maven) | before 1.5.0 | 1.5.0 | Patch available | GHSA-837x-xww6-7jqm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- postgresql:pljava-public (Maven) Vendor— Affected before 1.5.0 Fixed in 1.5.0 Patch available GHSA-837x-xww6-7jqm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pl\/java_project:pl\/java:*:*:*:*:*:postgresql:*:* | up to 1.4.3 | Vulnerable | Pl/java Project |
- cpe:2.3:a:pl\/java_project:pl\/java:*:*:*:*:*:postgresql:*:* Versions up to 1.4.3 Vulnerable ·Pl/java Project
Remediation
- Fix · GHSA-837x-xww6-7jqm postgresql:pljava-public (Maven) Fixed in 1.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0767
- 2026-10-03 Alias added: GHSA-837x-xww6-7jqm
References
More Pl/java Project Pl/java vulnerabilities
- TI-2016-02001 PostgreSQL PL/Java before 1.5.0 allows remote authenticated users to alter type mappings for types they do not own. CVSS 3.1MEDIUM 6.5
Sources
- CVE-2016-0767 · CVE Program
- CVE-2016-0767 · NVD
- FIRST EPSS
- GHSA-837x-xww6-7jqm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences