Buffer overflow in the ImagingFliDecode function in libImaging/FliDecode.c in Pillow…
Priority LOW 34CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Buffer overflow in the ImagingFliDecode function in libImaging/FliDecode.c in Pillow before 3.1.1 allows remote attackers to cause a denial of service (crash) via a crafted FLI file.
Why it matters now
EPSS 0.0252 84th percentileScored 2026-11-07
Fix Partial pillow (PyPI): 3.1.1Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pillow (PyPI) | before 3.1.1 | 3.1.1 | Patch available | GHSA-8xjv-v9xq-m5h9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pillow (PyPI) Vendor— Affected before 3.1.1 Fixed in 3.1.1 Patch available GHSA-8xjv-v9xq-m5h9
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* | up to 3.1.0 | Vulnerable | python-pillow |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* Versions up to 3.1.0 Vulnerable ·python-pillow
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-8xjv-v9xq-m5h9 pillow (PyPI) Fixed in 3.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0775
- 2026-10-03 Alias added: GHSA-8xjv-v9xq-m5h9
References
Advisory 4
Other 4
- https://github.com/python-pillow/Pillow/commit/893a40850c2d5da41537958e40569c029a6e127b
- https://github.com/python-pillow/Pillow/blob/c3cb690fed5d4bf0c45576759de55d054916c165/CHANGES.rst
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2016-6.yaml
- https://github.com/python-pillow/Pillow
Sources
- CVE-2016-0775 · CVE Program
- CVE-2016-0775 · NVD
- FIRST EPSS
- GHSA-8xjv-v9xq-m5h9 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-0775 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences