Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow…
Priority HIGH 79CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to execute arbitrary code via serialized data in an XML file, related to XStream and groovy.util.Expando.
Why it matters now
EPSS 0.83259 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by the CNA and NVD
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 1.650, 1.642.2Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.643 to before 1.650 | 1.650 | Patch available | GHSA-45rg-g72w-r393 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.642.2 | 1.642.2 | Patch available | GHSA-45rg-g72w-r393 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.643 to before 1.650 Fixed in 1.650 Patch available GHSA-45rg-g72w-r393
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.642.2 Fixed in 1.642.2 Patch available GHSA-45rg-g72w-r393
Remediation
- Fix · GHSA-45rg-g72w-r393 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.650 Advisory →
- Fix · GHSA-45rg-g72w-r393 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.642.2 Advisory →
Red Hat 2 advisories
- RHSA-2016:1773 Released 2016-08-24 · Red Hat rating ImportantRed Hat OpenShift Enterprise 2.2.10 security, bug fix, and enhancement update
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.38.7.1-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 activemq-5.9.0-6.redhat.611463.el6op, activemq-client-5.9.0-6.redhat.611463.el6op, openshift-origin-broker-1.16.3.2-1.el6op +5
- Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 openshift-origin-cartridge-jbosseap-2.27.4.2-1.el6op
- Red Hat OpenShift Enterprise Node 2.2 ImageMagick-6.7.2.7-5.el6_8, ImageMagick-devel-6.7.2.7-5.el6_8, ImageMagick-doc-6.7.2.7-5.el6_8 +24
- RHSA-2016:0711 Released 2016-05-03 · Red Hat rating Importantjenkins security update
- Red Hat OpenShift Enterprise 3.1 jenkins-1.642.2-1.el7, jenkins-plugin-credentials-1.24-2.el7, jenkins-plugin-durable-task-1.7-1.el7 +2
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:0711 |
| Red Hat OpenShift Enterprise Client 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise Infrastructure 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise Node 2.2 | Fixed | RHSA-2016:1773 |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-0792
- 2026-10-03 Alias added: GHSA-45rg-g72w-r393
References
Exploit 3
Sources
- CVE-2016-0792 · CVE Program
- CVE-2016-0792 · NVD
- FIRST EPSS
- GHSA-45rg-g72w-r393 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-0792 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences