Read the docs
TI-2016-01177 Aliases CVE-2016-1284GHSA-8xw7-2mqr-xwqh

rdataset.c in ISC BIND 9 Supported Preview Edition 9.9.8-S before 9.9.8-S5, when…

Priority LOW 32CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA.

Summary

rdataset.c in ISC BIND 9 Supported Preview Edition 9.9.8-S before 9.9.8-S5, when nxdomain-redirect is enabled, allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via crafted flag values in a query.

Why it matters now

EPSS 0.03403 88th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.9.8:s1:*:*:*:*:*:*9.9.8 s1VulnerableISC
cpe:2.3:a:isc:bind:9.9.8:s2:*:*:*:*:*:*9.9.8 s2VulnerableISC
cpe:2.3:a:isc:bind:9.9.8:s3:*:*:*:*:*:*9.9.8 s3VulnerableISC
cpe:2.3:a:isc:bind:9.9.8:s4:*:*:*:*:*:*9.9.8 s4VulnerableISC
  • cpe:2.3:a:isc:bind:9.9.8:s1:*:*:*:*:*:* Versions 9.9.8 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.8:s2:*:*:*:*:*:* Versions 9.9.8 s2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.8:s3:*:*:*:*:*:* Versions 9.9.8 s3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.8:s4:*:*:*:*:*:* Versions 9.9.8 s4 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-1284
  2. 2026-10-03 Alias added: GHSA-8xw7-2mqr-xwqh

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources