Read the docs
TI-2016-01381 Aliases CVE-2016-1494GHSA-8rjr-6qq5-pj9p

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows…

Priority LOW 34CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.

Summary

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.

Why it matters now

EPSS 0.06996 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed rsa (PyPI): 3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—rsa (PyPI)before 3.33.3Patch availableGHSA-8rjr-6qq5-pj9p
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • rsa (PyPI) Vendor— Affected before 3.3 Fixed in 3.3 Patch available GHSA-8rjr-6qq5-pj9p

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:python:rsa:*:*:*:*:*:python:*:*before 3.3Vulnerablepython-pillow
cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*22VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*23VulnerableFedoraproject
cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*42.1VulnerableopenSUSE
cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:*13.1VulnerableopenSUSE
cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*13.2VulnerableopenSUSE
  • cpe:2.3:a:python:rsa:*:*:*:*:*:python:*:* Versions before 3.3 Vulnerable ·python-pillow
  • cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
  • cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE

Remediation

  • Fix · GHSA-8rjr-6qq5-pj9p rsa (PyPI) Fixed in 3.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-1494
  2. 2026-10-03 Alias added: GHSA-8rjr-6qq5-pj9p

References

Sources