resolver.c in named in ISC BIND 9.10.x before 9.10.3-P4, when DNS cookies are enabled…
Priority MEDIUM 50CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
resolver.c in named in ISC BIND 9.10.x before 9.10.3-P4, when DNS cookies are enabled, allows remote attackers to cause a denial of service (INSIST assertion failure and daemon exit) via a malformed packet with more than one cookie option.
Why it matters now
EPSS 0.22715 97th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 29
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.10.0:*:*:*:*:*:*:* | 9.10.0 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:a1:*:*:*:*:*:* | 9.10.0 a1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:a2:*:*:*:*:*:* | 9.10.0 a2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:b1:*:*:*:*:*:* | 9.10.0 b1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:b2:*:*:*:*:*:* | 9.10.0 b2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:p1:*:*:*:*:*:* | 9.10.0 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:p2:*:*:*:*:*:* | 9.10.0 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:rc1:*:*:*:*:*:* | 9.10.0 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.0:rc2:*:*:*:*:*:* | 9.10.0 rc2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:*:*:*:*:*:*:* | 9.10.1 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:9.10.0:*:*:*:*:*:*:* Versions 9.10.0 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:a1:*:*:*:*:*:* Versions 9.10.0 a1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:a2:*:*:*:*:*:* Versions 9.10.0 a2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:b1:*:*:*:*:*:* Versions 9.10.0 b1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:b2:*:*:*:*:*:* Versions 9.10.0 b2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:p1:*:*:*:*:*:* Versions 9.10.0 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:p2:*:*:*:*:*:* Versions 9.10.0 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:rc1:*:*:*:*:*:* Versions 9.10.0 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.0:rc2:*:*:*:*:*:* Versions 9.10.0 rc2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:*:*:*:*:*:*:* Versions 9.10.1 Vulnerable ·ISC
Show 19 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.10.1:b1:*:*:*:*:*:* | 9.10.1 b1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:b2:*:*:*:*:*:* | 9.10.1 b2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:p1:*:*:*:*:*:* | 9.10.1 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:p2:*:*:*:*:*:* | 9.10.1 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:rc1:*:*:*:*:*:* | 9.10.1 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.1:rc2:*:*:*:*:*:* | 9.10.1 rc2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:b1:*:*:*:*:*:* | 9.10.2 b1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:p1:*:*:*:*:*:* | 9.10.2 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:p2:*:*:*:*:*:* | 9.10.2 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:p3:*:*:*:*:*:* | 9.10.2 p3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:p4:*:*:*:*:*:* | 9.10.2 p4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:rc1:*:*:*:*:*:* | 9.10.2 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.2:rc2:*:*:*:*:*:* | 9.10.2 rc2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:*:*:*:*:*:*:* | 9.10.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:b1:*:*:*:*:*:* | 9.10.3 b1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:p1:*:*:*:*:*:* | 9.10.3 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:p2:*:*:*:*:*:* | 9.10.3 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:p3:*:*:*:*:*:* | 9.10.3 p3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.3:rc1:*:*:*:*:*:* | 9.10.3 rc1 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:9.10.1:b1:*:*:*:*:*:* Versions 9.10.1 b1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:b2:*:*:*:*:*:* Versions 9.10.1 b2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:p1:*:*:*:*:*:* Versions 9.10.1 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:p2:*:*:*:*:*:* Versions 9.10.1 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:rc1:*:*:*:*:*:* Versions 9.10.1 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.1:rc2:*:*:*:*:*:* Versions 9.10.1 rc2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:b1:*:*:*:*:*:* Versions 9.10.2 b1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:p1:*:*:*:*:*:* Versions 9.10.2 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:p2:*:*:*:*:*:* Versions 9.10.2 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:p3:*:*:*:*:*:* Versions 9.10.2 p3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:p4:*:*:*:*:*:* Versions 9.10.2 p4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:rc1:*:*:*:*:*:* Versions 9.10.2 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.2:rc2:*:*:*:*:*:* Versions 9.10.2 rc2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:*:*:*:*:*:*:* Versions 9.10.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:b1:*:*:*:*:*:* Versions 9.10.3 b1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:p1:*:*:*:*:*:* Versions 9.10.3 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:p2:*:*:*:*:*:* Versions 9.10.3 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:p3:*:*:*:*:*:* Versions 9.10.3 p3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.3:rc1:*:*:*:*:*:* Versions 9.10.3 rc1 Vulnerable ·ISC
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 4
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2088
- 2026-10-03 Alias added: GHSA-8f3h-84p6-655j
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2016-2088 · CVE Program
- CVE-2016-2088 · NVD
- FIRST EPSS
- GHSA-8f3h-84p6-655j · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2088 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences