The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before…
Priority LOW 21CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 5 fixed, 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to enumerate users via a timing attack involving login requests.
Why it matters now
EPSS 0.03409 88th percentileScored 2026-11-07
Fix Partial Django (PyPI): 1.8.10, 1.9.3Red Hat: 5 advisoriesRed Hat: 5 fixed, 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 1.8.10 | 1.8.10 | Patch available | GHSA-fp6p-5xvw-m74f |
| — | Django (PyPI) | 1.9 to before 1.9.3 | 1.9.3 | Patch available | GHSA-fp6p-5xvw-m74f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 1.8.10 Fixed in 1.8.10 Patch available GHSA-fp6p-5xvw-m74f
- Django (PyPI) Vendor— Affected 1.9 to before 1.9.3 Fixed in 1.9.3 Patch available GHSA-fp6p-5xvw-m74f
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.8.9:*:*:*:*:*:*:* | 1.8.9 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.9:*:*:*:*:*:*:* | 1.9 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.9.1:*:*:*:*:*:*:* | 1.9.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.8.9:*:*:*:*:*:*:* Versions 1.8.9 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.9:*:*:*:*:*:*:* Versions 1.9 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-fp6p-5xvw-m74f Django (PyPI) Fixed in 1.8.10 Advisory →
- Fix · GHSA-fp6p-5xvw-m74f Django (PyPI) Fixed in 1.9.3 Advisory →
Red Hat 5 advisories
- RHSA-2016:0502 Released 2016-03-24 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 python-django-1.6.11-5.el6ost, python-django-bash-completion-1.6.11-5.el6ost, python-django-doc-1.6.11-5.el6ost
- RHSA-2016:0503 Released 2016-03-24 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 7.0 Operational Tools for RHEL 7 python-django-1.6.11-5.el7ost, python-django-bash-completion-1.6.11-5.el7ost
- RHSA-2016:0504 Released 2016-03-24 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 python-django-1.8.11-1.el7ost, python-django-bash-completion-1.8.11-1.el7ost, python-django-doc-1.8.11-1.el7ost
Show 2 more Red Hat advisories
- RHSA-2016:0505 Released 2016-03-24 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 python-django-1.6.11-5.el7ost, python-django-bash-completion-1.6.11-5.el7ost, python-django-doc-1.6.11-5.el7ost
- RHSA-2016:0506 Released 2016-03-24 · Red Hat rating Moderatepython-django security update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 python-django-1.6.11-5.el7ost, python-django-bash-completion-1.6.11-5.el7ost, python-django-doc-1.6.11-5.el7ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.2 | Affected | No fix planned: Will not fix |
| Red Hat Ceph Storage 1.3 | Affected | No fix planned: Will not fix |
| Red Hat Subscription Asset Manager | Affected | No fix yet |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | Fixed | RHSA-2016:0502 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | Fixed | RHSA-2016:0506 |
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | Fixed | RHSA-2016:0505 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 | Fixed | RHSA-2016:0504 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 Operational Tools for RHEL 7 | Fixed | RHSA-2016:0503 |
Not affected: 2 products
- Red Hat OpenStack Platform 8 (Liberty)
- Red Hat OpenStack Platform 8 (Liberty) Operational Tools
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2513
- 2026-10-03 Alias added: GHSA-fp6p-5xvw-m74f
References
Advisory 10
Other 9
- https://github.com/django/django/commit/67b46ba7016da2d259c1ecc7d666d11f5e1cfaab
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- https://github.com/django/django/commit/af7d09b0c5c6ab68e629fd9baf736f9dd203b18e
- https://github.com/django/django/commit/f4e6e02f7713a6924d16540be279909ff4091eb6
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2016-16.yaml
- https://web.archive.org/web/20160322001143/http://www.securitytracker.com/id/1035152
- https://web.archive.org/web/20200228001222/http://www.securityfocus.com/bid/83878
- https://www.djangoproject.com/weblog/2016/mar/01/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-2513 · CVE Program
- CVE-2016-2513 · NVD
- FIRST EPSS
- GHSA-fp6p-5xvw-m74f · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2513 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences