Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of…
Priority LOW 39CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.
Summary
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
Why it matters now
EPSS 0.0337 88th percentileScored 2026-11-07
Fix Partial hawk (npm): 4.1.1, 3.1.3Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | hawk (npm) | 4.0.0 to before 4.1.1 | 4.1.1 | Patch available | GHSA-jcpv-g9rr-qxrc |
| — | hawk (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-jcpv-g9rr-qxrc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- hawk (npm) Vendor— Affected 4.0.0 to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-jcpv-g9rr-qxrc
- hawk (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-jcpv-g9rr-qxrc
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hawk_project:hawk:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | Hawk Project |
| cpe:2.3:a:hawk_project:hawk:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Hawk Project |
- cpe:2.3:a:hawk_project:hawk:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·Hawk Project
- cpe:2.3:a:hawk_project:hawk:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Hawk Project
Remediation
- Fix · GHSA-jcpv-g9rr-qxrc hawk (npm) Fixed in 4.1.1 Advisory →
- Fix · GHSA-jcpv-g9rr-qxrc hawk (npm) Fixed in 3.1.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3.1 | Affected | — |
| Red Hat Software Collections | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2515
- 2026-10-03 Alias added: GHSA-jcpv-g9rr-qxrc
References
Patch 2
Advisory 2
Sources
- CVE-2016-2515 · CVE Program
- CVE-2016-2515 · NVD
- FIRST EPSS
- GHSA-jcpv-g9rr-qxrc · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2515 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences