Buffer overflow in the ImagingPcdDecode function in PcdDecode.c in Pillow before 3.1.1…
Priority LOW 36CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Buffer overflow in the ImagingPcdDecode function in PcdDecode.c in Pillow before 3.1.1 and Python Imaging Library (PIL) 1.1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted PhotoCD file.
Why it matters now
EPSS 0.04031 90th percentileScored 2026-11-07
Fix Partial pillow (PyPI): 3.1.1Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pillow (PyPI) | before 3.1.1 | 3.1.1 | Patch available | GHSA-3c5c-7235-994j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pillow (PyPI) Vendor— Affected before 3.1.1 Fixed in 3.1.1 Patch available GHSA-3c5c-7235-994j
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* | up to 3.1.0 | Vulnerable | python-pillow |
| cpe:2.3:a:python_imaging_project:python_imaging:*:*:*:*:*:*:*:* | up to 1.1.7 | Vulnerable | Python Imaging Project |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* Versions up to 3.1.0 Vulnerable ·python-pillow
- cpe:2.3:a:python_imaging_project:python_imaging:*:*:*:*:*:*:*:* Versions up to 1.1.7 Vulnerable ·Python Imaging Project
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-3c5c-7235-994j pillow (PyPI) Fixed in 3.1.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2533
- 2026-10-03 Alias added: GHSA-3c5c-7235-994j
References
Advisory 5
Other 9
- [oss-security] 20160222 Re: CVE Request -- Buffer overflow in Python-Pillow and PIL
- https://github.com/python-pillow/Pillow/commit/5bdf54b5a76b54fb00bd05f2d733e0a4173eefc9#diff-8ff6909c159597e22288ad818938fd6b
- [oss-security] 20160202 CVE Request -- Buffer overflow in Python-Pillow and PIL
- https://github.com/python-pillow/Pillow/commit/ae453aa18b66af54e7ff716f4ccb33adca60afd4#diff-8ff6909c159597e22288ad818938fd6b
- https://github.com/python-pillow/Pillow/pull/1706
- http://www.oracle.com/technetwork/topics/security/bulletinjan2016-2867206.html
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2016-19.yaml
- https://github.com/python-pillow/Pillow
- https://github.com/python-pillow/Pillow/blob/c3cb690fed5d4bf0c45576759de55d054916c165/CHANGES.rst?plain=1#L53
Sources
- CVE-2016-2533 · CVE Program
- CVE-2016-2533 · NVD
- FIRST EPSS
- GHSA-3c5c-7235-994j · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2533 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences