Multiple SQL injection vulnerabilities in the scoped_search function in…
Priority MEDIUM 42CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.
Summary
Multiple SQL injection vulnerabilities in the scoped_search function in app/controllers/katello/api/v2/api_controller.rb in Katello allow remote authenticated users to execute arbitrary SQL commands via the (1) sort_by or (2) sort_order parameter.
Why it matters now
EPSS 0.01835 79th percentileScored 2026-11-07
Fix Fixed katello (RubyGems): 2.4.3Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | katello (RubyGems) | before 2.4.3 | 2.4.3 | Patch available | GHSA-527r-mfmj-prqf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- katello (RubyGems) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-527r-mfmj-prqf
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:katello:katello:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Katello |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Running on | Red Hat |
| cpe:2.3:a:redhat:satellite:6.1:*:*:*:*:*:*:* | 6.1 | Vulnerable | Red Hat |
- cpe:2.3:a:katello:katello:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Katello
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat
- cpe:2.3:a:redhat:satellite:6.1:*:*:*:*:*:*:* Versions 6.1 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-527r-mfmj-prqf katello (RubyGems) Fixed in 2.4.3 Advisory →
Red Hat 1 advisory
- RHSA-2016:1083 Released 2016-05-16 · Red Hat rating Importantruby193-rubygem-katello security update
- Red Hat Satellite 6.1 ruby193-rubygem-katello-2.2.0.86-1.el6_6sat, ruby193-rubygem-katello-2.2.0.86-1.el7sat
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.1 | Fixed | RHSA-2016:1083 |
Not affected: 1 product
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3072
- 2026-10-03 Alias added: GHSA-527r-mfmj-prqf
References
Other 5
- https://bugzilla.redhat.com/show_bug.cgi?id=1322050
- https://github.com/Katello/katello/commit/5645ed4365980a34e30a9c57fe0793dff729e8e4
- https://access.redhat.com/security/cve/CVE-2016-3072
- https://github.com/Katello/katello
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/katello/CVE-2016-3072.yml
Sources
- CVE-2016-3072 · CVE Program
- CVE-2016-3072 · NVD
- FIRST EPSS
- GHSA-527r-mfmj-prqf · GitHub Advisory Database · CC BY 4.0
- CVE-2016-3072 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences