Read the docs
TI-2016-02595 Aliases CVE-2016-3096GHSA-rh6x-qvg7-rrmj

The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x…

Priority LOW 34CWE-59Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-script, (2) the archived container in the archive_path directory, or the (3) lxc-attach-script.log or (4) lxc-attach-script.err files in the temporary directory.

Why it matters now

EPSS 0.00468 40th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 2.0.2.0, 1.9.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ansible (PyPI)2.0.0.0 to before 2.0.2.02.0.2.0Patch availableGHSA-rh6x-qvg7-rrmj
—ansible (PyPI)before 1.9.6.11.9.6.1Patch availableGHSA-rh6x-qvg7-rrmj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected 2.0.0.0 to before 2.0.2.0 Fixed in 2.0.2.0 Patch available GHSA-rh6x-qvg7-rrmj
  • ansible (PyPI) Vendor— Affected before 1.9.6.1 Fixed in 1.9.6.1 Patch available GHSA-rh6x-qvg7-rrmj

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*22VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:*23VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:24:*:*:*:*:*:*:*24VulnerableFedoraproject
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*up to 1.9.6VulnerableRed Hat
cpe:2.3:a:redhat:ansible:2.0:*:*:*:*:*:*:*2.0VulnerableRed Hat
cpe:2.3:a:redhat:ansible:2.0.1:*:*:*:*:*:*:*2.0.1VulnerableRed Hat
  • cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:* Versions 22 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:23:*:*:*:*:*:*:* Versions 23 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:24:*:*:*:*:*:*:* Versions 24 Vulnerable ·Fedoraproject
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions up to 1.9.6 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-rh6x-qvg7-rrmj ansible (PyPI) Fixed in 2.0.2.0 Advisory →
  • Fix · GHSA-rh6x-qvg7-rrmj ansible (PyPI) Fixed in 1.9.6.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Enterprise 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-3096
  2. 2026-10-03 Alias added: GHSA-rh6x-qvg7-rrmj

References

Sources