Jenkins before 2.3 and LTS before 1.651.2 allow remote authenticated users with extended…
Priority LOW 33CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Jenkins before 2.3 and LTS before 1.651.2 allow remote authenticated users with extended read access to obtain sensitive password information by reading a job configuration.
Why it matters now
EPSS 0.02185 82nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.3, 1.651.2Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.652 to before 2.3 | 2.3 | Patch available | GHSA-7vvj-qqvj-h8mc |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.651.2 | 1.651.2 | Patch available | GHSA-7vvj-qqvj-h8mc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.652 to before 2.3 Fixed in 2.3 Patch available GHSA-7vvj-qqvj-h8mc
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.651.2 Fixed in 1.651.2 Patch available GHSA-7vvj-qqvj-h8mc
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openshift:3.1:*:*:*:enterprise:*:*:* | 3.1 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift:3.2:*:*:*:enterprise:*:*:* | 3.2 | Vulnerable | Red Hat |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* | up to 1.649 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* | up to 1.651.1 | Vulnerable | Jenkins |
- cpe:2.3:a:redhat:openshift:3.1:*:*:*:enterprise:*:*:* Versions 3.1 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift:3.2:*:*:*:enterprise:*:*:* Versions 3.2 Vulnerable ·Red Hat
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 1.649 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 1.651.1 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-7vvj-qqvj-h8mc org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.3 Advisory →
- Fix · GHSA-7vvj-qqvj-h8mc org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.651.2 Advisory →
Red Hat 2 advisories
- RHSA-2016:1773 Released 2016-08-24 · Red Hat rating ImportantRed Hat OpenShift Enterprise 2.2.10 security, bug fix, and enhancement update
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.38.7.1-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 activemq-5.9.0-6.redhat.611463.el6op, activemq-client-5.9.0-6.redhat.611463.el6op, openshift-origin-broker-1.16.3.2-1.el6op +5
- Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 openshift-origin-cartridge-jbosseap-2.27.4.2-1.el6op
- Red Hat OpenShift Enterprise Node 2.2 ImageMagick-6.7.2.7-5.el6_8, ImageMagick-devel-6.7.2.7-5.el6_8, ImageMagick-doc-6.7.2.7-5.el6_8 +24
- RHSA-2016:1206 Released 2016-06-06 · Red Hat rating Moderatejenkins security update
- Red Hat OpenShift Container Platform 3.2 jenkins-1.651.2-1.el7, jenkins-plugin-openshift-pipeline-1.0.12-1.el7
- Red Hat OpenShift Enterprise 3.1 jenkins-1.651.2-1.el7, jenkins-plugin-openshift-pipeline-1.0.12-1.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.2 | Fixed | RHSA-2016:1206 |
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:1206 |
| Red Hat OpenShift Enterprise Client 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise Infrastructure 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 | Fixed | RHSA-2016:1773 |
| Red Hat OpenShift Enterprise Node 2.2 | Fixed | RHSA-2016:1773 |
Timeline
- 2026-10-02 Threatist record created from CVE-2016-3724
- 2026-10-03 Alias added: GHSA-7vvj-qqvj-h8mc
References
Sources
- CVE-2016-3724 · CVE Program
- CVE-2016-3724 · NVD
- FIRST EPSS
- GHSA-7vvj-qqvj-h8mc · GitHub Advisory Database · CC BY 4.0
- CVE-2016-3724 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences