Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.
Why it matters now
EPSS 0.02085 81st percentileScored 2026-11-07
Fix Fixed horizon (PyPI): 8.0.2, 9.1.0Red Hat: 5 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | horizon (PyPI) | before 8.0.2 | 8.0.2 | Patch available | GHSA-grm6-x6mr-q3cv |
| — | horizon (PyPI) | 9.0.0 to before 9.1.0 | 9.1.0 | Patch available | GHSA-grm6-x6mr-q3cv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- horizon (PyPI) Vendor— Affected before 8.0.2 Fixed in 8.0.2 Patch available GHSA-grm6-x6mr-q3cv
- horizon (PyPI) Vendor— Affected 9.0.0 to before 9.1.0 Fixed in 9.1.0 Patch available GHSA-grm6-x6mr-q3cv
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openstack:horizon:*:*:*:*:*:*:*:* | 8.0.0 – 8.0.1 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:horizon:9.0.0:*:*:*:*:*:*:* | 9.0.0 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:horizon:9.0.1:*:*:*:*:*:*:* | 9.0.1 | Vulnerable | OpenStack |
| cpe:2.3:a:redhat:openstack:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack:8:*:*:*:*:*:*:* | 8 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Running on | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:openstack:horizon:*:*:*:*:*:*:*:* Versions 8.0.0 – 8.0.1 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:horizon:9.0.0:*:*:*:*:*:*:* Versions 9.0.0 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:horizon:9.0.1:*:*:*:*:*:*:* Versions 9.0.1 Vulnerable ·OpenStack
- cpe:2.3:a:redhat:openstack:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack:8:*:*:*:*:*:*:* Versions 8 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-grm6-x6mr-q3cv horizon (PyPI) Fixed in 8.0.2 Advisory →
- Fix · GHSA-grm6-x6mr-q3cv horizon (PyPI) Fixed in 9.1.0 Advisory →
Red Hat 5 advisories
- RHSA-2016:1269 Released 2016-06-21 · Red Hat rating Importantpython-django-horizon security update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 openstack-dashboard-2014.1.5-4.el7ost, openstack-dashboard-theme-2014.1.5-4.el7ost, python-django-horizon-2014.1.5-4.el7ost +1
- RHSA-2016:1272 Released 2016-06-21 · Red Hat rating Importantpython-django-horizon security, bug fix, and enhancement update
- Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 openstack-dashboard-2015.1.4-1.el7ost, openstack-dashboard-theme-2015.1.4-1.el7ost, python-django-horizon-2015.1.4-1.el7ost +1
- RHSA-2016:1268 Released 2016-06-21 · Red Hat rating Importantpython-django-horizon security update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 openstack-dashboard-2014.1.5-4.el6ost, openstack-dashboard-theme-2014.1.5-4.el6ost, python-django-horizon-2014.1.5-4.el6ost +1
Show 2 more Red Hat advisories
- RHSA-2016:1270 Released 2016-06-21 · Red Hat rating Importantpython-django-horizon security update
- Red Hat OpenStack Platform 8.0 (Liberty) openstack-dashboard-1:8.0.1-4.el7ost, openstack-dashboard-theme-1:8.0.1-4.el7ost, python-django-horizon-1:8.0.1-4.el7ost
- RHSA-2016:1271 Released 2016-06-21 · Red Hat rating Importantpython-django-horizon security and bug fix update
- Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 openstack-dashboard-2014.2.3-9.el7ost, openstack-dashboard-theme-2014.2.3-9.el7ost, python-django-horizon-2014.2.3-9.el7ost +1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | Fixed | RHSA-2016:1268 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | Fixed | RHSA-2016:1269 |
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | Fixed | RHSA-2016:1271 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 | Fixed | RHSA-2016:1272 |
| Red Hat OpenStack Platform 8.0 (Liberty) | Fixed | RHSA-2016:1270 |
Not affected: 2 products
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 9 (Mitaka)
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4428
- 2026-10-03 Alias added: GHSA-grm6-x6mr-q3cv
References
Patch 5
Advisory 8
Other 5
- https://github.com/openstack/horizon/commit/62b4e6f30a7ae7961805abdffdb3c7ae5c2b676a
- https://github.com/openstack/horizon/commit/d585e5eb9acf92d10d39b6c2038917a7e8ac71bb
- https://github.com/openstack/horizon/commit/fc8d70560401f3985e5672a4c580f10d51e985a4
- https://access.redhat.com/security/cve/CVE-2016-4428
- https://bugzilla.redhat.com/show_bug.cgi?id=1343982
Sources
- CVE-2016-4428 · CVE Program
- CVE-2016-4428 · NVD
- FIRST EPSS
- GHSA-grm6-x6mr-q3cv · GitHub Advisory Database · CC BY 4.0
- CVE-2016-4428 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences