Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a…
Priority MEDIUM 49CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0785.
Why it matters now
EPSS 0.08085 94th percentileScored 2026-11-07
Fix Fixed org.apache.struts:struts2-core (Maven): 2.3.29
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 2.3.29 | 2.3.29 | Patch available | GHSA-864w-r5qj-h6fj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.3.29 Fixed in 2.3.29 Patch available GHSA-864w-r5qj-h6fj
Remediation
- Fix · GHSA-864w-r5qj-h6fj org.apache.struts:struts2-core (Maven) Fixed in 2.3.29 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4461
- 2026-10-03 Alias added: GHSA-864w-r5qj-h6fj
References
Sources
- CVE-2016-4461 · CVE Program
- CVE-2016-4461 · NVD
- FIRST EPSS
- GHSA-864w-r5qj-h6fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences