Information disclosure in Apple Safari
Priority LOW 37CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
A Cross-origin vulnerability exists in WebKit in Apple Safari before 10.0.1 when processing location attributes, which could let a remote malicious user obtain sensitive information.
Why it matters now
EPSS 0.02011 80th percentileScored 2026-11-07
Fix Fixed Safari (Apple): 10.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | Safari | before 10.0.1 | 10.0.1 | Patch available | CNA |
- Safari VendorApple Affected before 10.0.1 Fixed in 10.0.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* | before 10.0.1 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.10.5:*:*:*:*:*:*:* | 10.10.5 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:*:*:*:*:*:*:* | 10.11.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12:*:*:*:*:*:*:* | 10.12 | Vulnerable | Apple |
- cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* Versions before 10.0.1 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.10.5:*:*:*:*:*:*:* Versions 10.10.5 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:*:*:*:*:*:*:* Versions 10.11.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12:*:*:*:*:*:*:* Versions 10.12 Vulnerable ·Apple
Remediation
- Fix · CNA Safari (Apple) Fixed in 10.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2016-4676
- 2026-10-03 Alias added: GHSA-x5qv-v22x-8gfj
References
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2016-4676 · CVE Program
- CVE-2016-4676 · NVD
- FIRST EPSS
- GHSA-x5qv-v22x-8gfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences